gratifiant > linux.debian.user.french

toto (23/07/2019, 17h50)
Bonjour à tous !

Mon "sudo dmesg -H" affiche les mots erreurs suivants (sous buster 10.0.0 -
64 bits - bios UEFI) :

1) acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM

2) ACPI BIOS Error (bug): Could not resolve [\_SB.PCI0.GFX0.DD02._BCL],
AE_NOT_FOUND (20180810/psargs-330)
ACPI Error: Method parse/execution failed \_SB.PCI0.RP05.PEGP.DD02._BCL,
AE_NOT_FOUND (20180810/psparse-516)

3) EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro

4) hp_wmi: query 0xd returned error 0x5

Je souhaiterais simplement corriger l'erreur 2) si nécessaire.
Si vous voulez des infos supplémentaires n'hésitez pas à me donner les
commandes à taper pour vous renseigner.

Merci.

Remaque / Info : j'ai du lancer update-initramfs à la main pour que le
firmware non-free de ma carte ati soit pris en compte au boot. En effet sous
stretch il me semble que je n'avais pas eu besoin de le faire ?
Pascal Hambourg (23/07/2019, 20h40)
Le 23/07/2019 à 17:25, toto a écrit :
> 3) EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro


Ce n'est pas une erreur. C'est le remontage de la racine avec les
options spécifiées dans /etc/fstab (le montage initial étant fait en
lecture seule par l'initramfs avant qu'il puisse lire /etc/fstab puisque
la racine n'est pas encore montée).
Aucune idée concernant les autre messages.

> Remaque / Info : j'ai du lancer update-initramfs à la main pour que le
> firmware non-free de ma carte ati soit pris en compte au boot. En effet sous
> stretch il me semble que je n'avais pas eu besoin de le faire ?


Il se pourrait donc que le module radeon ou amdgpu soit inclus dans
l'initramfs de Buster. Ce n'était pas le cas dans Stretch.
Vérifiable avec lsinitramfs /boot/initrd.img-<version>
Étienne Mollier (24/07/2019, 00h20)
toto, au 2019-07-23 :
> 1) acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
> 2) ACPI BIOS Error (bug): Could not resolve [\_SB.PCI0.GFX0.DD02._BCL],
> AE_NOT_FOUND (20180810/psargs-330)
> ACPI Error: Method parse/execution failed \_SB.PCI0.RP05.PEGP.DD02._BCL,
> AE_NOT_FOUND (20180810/psparse-516)


Bonjour,

Pour complémenter la réponse de Pascal, ces messages sont
engendrés par la détection d'un certain niveau de support pour
la gestion de l'énergie sur divers composants de votre machine,
mais le noyau échoue à l'implémenter. Une raison assez courante
est que le matériel ne publie pas correctement ces informations
au noyau, qui préférera alors ne pas faire usage de ces
fonctionnalités, et s'en plaindra bruyamment dans `dmesg` dans
la man?uvre.

La conséquence de ce genre de message est que votre machine
économise un peut moins d'électricité que ce qu'elle pourrait,
en laissant les composants non gérés sous tension. Ceci étant,
il vaut mieux avoir un composant qui reste sous tension, plutôt
qu'un composant qui n'arrive pas à redémarrer après veille...

Étant donné que la correction de genre de bug requiert de mettre
à jour le firmware de la carte mère, opération relativement
simple, mais peu anodine car pouvant briquer la machine si une
coupure de courant a lieu pendant la procédure, et que les
effets ne sont pas ou peu remarquables sans faire de mesures ;
j'ai comme l'impression que beaucoup de monde range ce genre de
message relatif à l'ACPI, soit dans la catégorie « bruit », soit
dans la catégorie « cause perdue ». Ça dépend des sensibilités.
Assez paradoxalement, les mises à jour fréquentes de noyau ont
tendance à faire apparaître de plus en plus de message de ce
genre sur une carte mère donnée.

L'article de Wikipedia en Anglais sur le sujet n'est pas de la
plus grande qualité, mais globalement, la question de
standardiser cette couche a fini par être confiée au groupe
ayant en charge l'UEFI :




Toute la partie relative à la carte mère a l'air désormais
unifié autour d'UEFI.org. Pendant ce temps, sur le traqueur de
bugs du noyau :



En bref, cette affaire a un petit côté « tonneau des Danaïdes ».
Je comprendrais que le sujet refroidisse du monde. Si vous vous
sentez de mettre à jour votre carte mère, ça peut éventuellement
avoir un effet positif quant à corriger ces messages. Sinon, ça
ne devrait pas avoir une incidence excessivement néfaste de les
négliger.

Amicalement,
toto (25/07/2019, 20h40)
Bonjour.

Pour le "lsinitramfs /boot/initrd.img-4.19.0-5-amd64" cela donne entre autre
:

usr/lib/firmware/radeon/RS600_cp.bin

En effet "dmesg -H" me signalait un probleme de firmware "R600".

Merci.
toto (25/07/2019, 20h40)
Bonjour.

Ok pour les renseignements. Je ne m'inquietes pas trop donc.

Merci.
Discussions similaires