gratifiant > microsoft.* > microsoft.excel

cris570 (15/11/2004, 13h04)
Bonjour,

ci-dessous j'ai une cellule ( VILLE ) dans laquelle j'écris le nom d'une
commune de France
et dans la cellule ( C.P.) devrait s'afficher le code postale de celle-ci.
Voici la fomule :

=SI(I2="";"";RECHERCHEV(I2;'Codes Postaux'!$A$1:$B$33827;1;0))

Ville : Langres
C.P. : #N/A

Mais j'ai #N/A qui s'affiche ???
Merci de m'aider.

Chris
Philippe.R (15/11/2004, 13h17)
Bonjour,
Laisse tomber recherchev !
=si(i2="";"";INDEX(villes;EQUIV(i2;codespost;0)))
devrait fonctionner, avec ta liste de villes nommée villes et celles des codes postaux figurant en
regard nommée codespost
Pounet95 (15/11/2004, 13h31)
Bonjour,
Sauf erreur, en I2 c'est la ville de Langres ?
Donc la recherche se fait sur une liste composée de 2 colonnes dont la
première DOIT contenir les noms de villes
et la 2ème le code postal correspondant.
Si c'est le cas la formule est :
=SI(I2="";"";RECHERCHEV(I2;'Codes Postaux'!$A$1:$B$33827;2;FAUX))

nota : la colonne Ville a le n°1, les CP le n° 2

Est-ce OK ?
cris570 (15/11/2004, 14h46)
Cela marche mais partiellement, toutes les codes ne s'affichent pas

"Pounet95" <pasdepub> a écrit dans le message de news:
O8wGnawyEHA.1300...
[..]
cris570 (15/11/2004, 15h17)
J'ai aussi un autre problème, si dans les communes j'en ai deux ou plus qui
portent le même nom s'affiche le code postal de la 1ère commune

23e8eFExyEHA.4044...
[..]
Christian.L (15/11/2004, 16h09)
Bonjour

C'est normal, et si les deux nom sont parfaitement identique, imparable !!
En effet, Excel arrête la recherche sur la première correspondance trouvée

C.L.

"cris570" <cris570> a écrit dans le message de
news:1196
[..]
AV (15/11/2004, 16h23)
> J'ai aussi un autre problème, si dans les communes j'en ai deux ou plus qui
> portent le même nom s'affiche le code postal de la 1ère commune


Jusque là, tout est normal !

Pour trouver la ville correspondant à la 1° occurrence du code postal contenu en
I2
Soluce donnée par Phillipe.R
=INDEX(Villes;EQUIV(I2;CodePostaux;0))
Pour trouver la ville correspondant à la X° occurrence du code postal contenu en
I2
Matricielle (validation par ctrl+maj+entrée)
=INDEX(Villes;PETITE.VALEUR(SI(CodePostaux=I2;LIGN E(CodePostaux); "");X))

AV
Daniel.M (15/11/2004, 17h21)
Bonjour Alain,

> Pour trouver la ville correspondant à la X° occurrence du
> code postal contenu en I2
> Matricielle (validation par ctrl+maj+entrée)


> =INDEX(Villes;PETITE.VALEUR(SI(CodePostaux=I2;LIGN E(CodePostaux); "");X))


Ça fonctionne si tes données commencent en ligne 1.
Autrement :

=INDEX(Villes;PETITE.VALEUR(SI(CodePostaux=I2;LIGN E(CodePostaux); "")
;X)+1-MIN(LIGNE(CodePostaux)))

Avec un #NUM si on ne retrouve de Xième occurence.

Salutations,

Daniel M.
AV (15/11/2004, 17h30)
Ave Daniel,

> Ça fonctionne si tes données commencent en ligne 1.


Je suis d'accord ...
Ton rajout est judicieux

AV
Daniel.M (15/11/2004, 17h48)
Il y a celle-ci, plus 'classique':

=INDEX(Villes;PETITE.VALEUR(SI(CodePostaux=I2;
LIGNE(INDIRECT("1:"&LIGNES(CodePostaux))));X))

Salutations,

Daniel M.
AV (15/11/2004, 18h11)
Tant qu'on y est..
Avec tableau nommé "tablo" (ex. A1:Bx avec CP en A1:Ax et Villes en B1:Bx)
Matricielle
=INDEX(tablo;PETITE.VALEUR(SI(DECALER(tablo;;;;1)= I2;LIGNE(tablo));X)-LIGNE(tabl
o)+1;2)

Ca devrait laisser le choix.....
AV
cris570 (16/11/2004, 12h32)
Merci à tous,
j'ai renommé la feuille Codes Postaux en tablo, mes données commences en
ligne 1 sur 2 colonnes,
colonne 1 le nom des communes ( 33827 ) et en colonne 2 le code postal
correspondant. J'ai écris la formule

=INDEX(tablo;PETITE.VALEUR(SI(DECALER(tablo;;;;1)= I2;LIGNE(tablo));X)-LIGNE(tablo)+1;2)

Et j'ai #NOM? qui s'affiche, je ne suis pas un pro d'excel,
merci de votre aide

"AV" <alainPFFFvallon> a écrit dans le message de news:
eOPMr3yyEHA.3808...
[..]
Pounet95 (16/11/2004, 12h36)
Bonjour,
Si je lis ce qu'a écrit MV ci-dessous, ce n'est pas la feuille qu'il faut
nommer 'tablo' mais le tableau des données, non ?
cris570 (16/11/2004, 12h45)
Ok, mais ce tableau des données je le créer où ?
Car j'ai la 1ère feuille sur lequel j'écris les noms de ville
une 2ème ou j'ai les données de calcul des devis, une 3ème pour l'édition du
devis et une 4ème les codes postaux

"Pounet95" <pasdepub> a écrit dans le message de news:
%23dyeug8yEHA.1188...
[..]
AV (16/11/2004, 12h54)
Exemple là :



AV

Discussions similaires