gratifiant > linux.debian.user.french

Gaëtan PERRIER (21/02/2015, 01h50)
Bonjour,

La version d'hplip dans debian date d'il y a plus de 8 mois
(3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si longue.
Du coup nombre d'imprimantes en vente actuellement nécessite au moins la
version 3.14.10.
Je me demande donc si quelqu'un a déjà installer hplip depuis le wizarddu
site ? Est-ce ça pose des problèmes ?

Gaëtan
yamo' (21/02/2015, 12h00)
Salut,

Gaëtan PERRIER a écrit le 21/02/2015 00:50 :
> Bonjour,
> La version d'hplip dans debian date d'il y a plus de 8 mois
> (3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si longue.
> Du coup nombre d'imprimantes en vente actuellement nécessite au moins la
> version 3.14.10.
> Je me demande donc si quelqu'un a déjà installer hplip depuis le wizard du
> site ? Est-ce ça pose des problèmes ?


Je ne sais pas mais, tu as deux méthodes d'installation (pour la
deuxième qui devrait mieux fonctionner, je ferais checkinstall au lieu
de make install) :

<http://linuxg.net/how-to-install-hplip-3-15-2-on-linux-systems/>
<http://hplipopensource.com/hplip-web/install/manual/distros/debian.html>

Je ne peux pas en dire plus, je n'ai que du canon chez moi.
Gaëtan PERRIER (22/02/2015, 17h30)
Le Sat, 21 Feb 2015 10:31:51 +0100
yamo' <yamo> a écrit:

> Salut,
> Gaëtan PERRIER a écrit le 21/02/2015 00:50 :
> Je ne sais pas mais, tu as deux méthodes d'installation (pour la
> deuxième qui devrait mieux fonctionner, je ferais checkinstall au lieu
> de make install) :
> <http://linuxg.net/how-to-install-hplip-3-15-2-on-linux-systems/>
> <http://hplipopensource.com/hplip-web/install/manual/distros/debian.html>


Effectivement je n'avais pas fait attention à cette méthode. Si quelqu'un à
des retours ? Faut-il d'abord enlever les paquets debian ?

> Je ne peux pas en dire plus, je n'ai que du canon chez moi.


Les pilotes sont sous quel licence ? Est-ce que l'on a une pérennité en
fonction des évolutions de Linux. Je n'ai pas envie de retomber dans le
problème que j'ai eu avec mon scanner Epson qui avait un pilote proprio et
dont j'ai du me séparer quand je suis passé en 64 bits car epson n'a pas
fournit de version 64 bits pour les scanner anciens.

Gaëtan
Romain Casati (23/02/2015, 09h50)
Bonjour

On 21/02/2015 00:41, Gaëtan PERRIER wrote:
> Bonjour,
> La version d'hplip dans debian date d'il y a plus de 8 mois
> (3.14.6) et la durée de vie des imprimantes sur le marché n'est passi longue.
> Du coup nombre d'imprimantes en vente actuellement nécessite au moinsla
> version 3.14.10.
> Je me demande donc si quelqu'un a déjà installer hplip depuis le wizard du
> site ? Est-ce ça pose des problèmes ?
> Gaëtan


J'ai récemment installé une HP ENVY 4507 sur une Debian stable 32bitsen
suivant ces instructions :



J'avais pris soin de désinstaller le paquet hplib et tout a bien
fonctionné, même l'impression recto-verso (duplex) et le scanner ! Ça a
un peu râlé au début, disant que le pilote n'était compatible qu'avec
Debian 7.6 et que 7.8 n'était pas supporté mais c'était juste un
avertissement.

Bonne installation,
Romain Casati (23/02/2015, 10h10)
On 22/02/2015 16:27, Gaëtan PERRIER wrote:
> Le Sat, 21 Feb 2015 10:31:51 +0100
> yamo' <yamo> a écrit:
> Effectivement je n'avais pas fait attention à cette méthode. Si quelqu'un à
> des retours ? Faut-il d'abord enlever les paquets debian ?
> Les pilotes sont sous quel licence ? Est-ce que l'on a une pérennitéen
> fonction des évolutions de Linux. Je n'ai pas envie de retomber dans le
> problème que j'ai eu avec mon scanner Epson qui avait un pilote proprio et
> dont j'ai du me séparer quand je suis passé en 64 bits car epson n'a pas
> fournit de version 64 bits pour les scanner anciens.


D'après cette page , les pilotes
sont sous trois licences libres GPLv2, MIT et BSD (c'est indiqué dans
l'en-tête de chaque fichier apparemment). Il y a aussi ce petit
paragraphe qui m'interroge :

"A small subset of HP devices require proprietary software technologies
to allow full access to printer features and performance. These
technologies cannot be open sourced. Because of this, HP is releasing
binary plug-ins for each of these printers that work in conjunction with
our Linux Open Source Printing Software to improve the printing
experience for HP’s Linux Printing Customers. These binary plug-ins
require the user to read and agree to a license agreement at the time of
driver installation."

Je n'ai pas le souvenir d'avoir accepté une licence au moment de
l'installation... Cependant, le paquet hplip de Debian est sur la
branche main et pas non-free.

Concernant ton problème, n'était-il pas possible d'installer les paquets
32bit nécessaires même sur ton architecture 64bit afin de faire
fonctionner les pilotes Epson ? C'est assez facile avec Debian, il y a
un tutoriel ici .

Romain
Sylvain L. Sauvage (23/02/2015, 12h30)
Le lundi 23 février 2015, 09:03:51 Romain Casati a écrit :
>[?]
> D'après cette page , les
> pilotes sont sous trois licences libres GPLv2, MIT et BSD
> [?]


Gaëtan parlait des pilotes Canon? dont je suppose la licence
(suis pas allé voir le site) empêche de faire des paquets?

?

[..]
> Je n'ai pas le souvenir d'avoir accepté une licence au moment
> de l'installation... Cependant, le paquet hplip de Debian est
> sur la branche main et pas non-free.


Ça doit concerner des micrologiciels (firmware) pour certains
produits. S?ils ne sont pas fournis dans Debian, pas besoin
d?EULA.
Erwan David (23/02/2015, 12h50)
On Mon, Feb 23, 2015 at 11:29:26AM CET, "Sylvain L. Sauvage" <Sylvain.L.Sauvage> said:
> Le lundi 23 février 2015, 09:03:51 Romain Casati a écrit :
> Gaëtan parlait des pilotes Canon? dont je suppose la licence
> (suis pas allé voir le site) empêche de faire des paquets?
> ?
> Ça doit concerner des micrologiciels (firmware) pour certains
> produits. S?ils ne sont pas fournis dans Debian, pas besoin
> d?EULA.


hplip ne contient pas ces softs, mais peut les télécharger et c'est à
ce moment là que la question est posée (j'ai du accepter cette licence
pour un binaire pour ma laserjet M125
Gaëtan PERRIER (24/02/2015, 23h40)
Le Mon, 23 Feb 2015 08:47:12 +0100
Romain Casati <romain.casati> a écrit:

[..]
> avertissement.
> Bonne installation,
> Romain


Merci pour ton retour.

Gaëtan

PS: réponse tardive, le message était dans les spams ...
yamo' (25/02/2015, 14h20)
Salut,

Gaëtan PERRIER a écrit le 22/02/2015 16:30 :
> Le Sat, 21 Feb 2015 10:31:51 +0100
> yamo' <yamo> a écrit:


>> <http://linuxg.net/how-to-install-hplip-3-15-2-on-linux-systems/>
>> <http://hplipopensource.com/hplip-web/install/manual/distros/debian.html>

> Effectivement je n'avais pas fait attention à cette méthode. Si quelqu'un à
> des retours ? Faut-il d'abord enlever les paquets debian ?


En faisant checkinstall (sans le make install), ce ne sera pas utile.

>> Je ne peux pas en dire plus, je n'ai que du canon chez moi.

> Les pilotes sont sous quel licence ? Est-ce que l'on a une pérennité en
> fonction des évolutions de Linux. Je n'ai pas envie de retomber dans le
> problème que j'ai eu avec mon scanner Epson qui avait un pilote proprio et
> dont j'ai du me séparer quand je suis passé en 64 bits car epson n'a pas
> fournit de version 64 bits pour les scanner anciens.


C'est très variable. Mais en fait, je ne les utilise que très rarement
et je n'ai pas eu le temps de m'en occuper sérieusement ; elles ne sont
pas installées sauf sur un viel ordi sur debian squeeze. Et j'ai un
problème de configuration de cups. Là mon IP4200 bien que branchée sur
une debian squeeze n'est réellement utilisée que sur un XP bidouillé
pour qu'il n'aille pas sur le net...
J'en ai une autre que je n'ai pas réussit à faire fonctionner en 64bits!

Les imprimantes : une imprimante achetée il y a longtemps quand j'étais
sur windows, l'autre j'avais vérifié qu'elle était supportée et en fait
c'est pas vraiment le cas...
La prochaine ne sera probablement pas une canon.
Gaëtan PERRIER (27/02/2015, 02h20)
Le Mon, 23 Feb 2015 08:47:12 +0100
Romain Casati <romain.casati> a écrit:

[..]
> avertissement.
> Bonne installation,
> Romain


Salut,

Je suis passé par la méthode manuelle

avec checkinstall
Il faut enlever les paquets hplip existant car il y des conflits avec le
paquet généré.
L'imprimante est bien reconnue par contre le scanner ...
Pour info je suis relié en ethernet.

Gaëtan
Gaëtan PERRIER (03/03/2015, 02h10)
Le Fri, 27 Feb 2015 01:15:23 +0100
Gaëtan PERRIER <gaetan.perrier> a écrit:

> L'imprimante est bien reconnue par contre le scanner ...
> Pour info je suis relié en ethernet.


Quand je lance hp-scan voici ce qu'il me dit:

HP Linux Imaging and Printing System (ver. 3.15.2)
Scan Utility ver. 2.2

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hpaio:/net/ENVY_7640_series?ip=192.168.1.81

warning: No destinations specified. Adding 'file' destination by default.
error: Unable to locate device hpaio:/net/ENVY_7640_series?ip=192.168.1.81
using SANE backend hpaio:. Please check HPLIP installation.

Je ne sais pas quoi vérifier et où vérifier dans mon installation hplip ?

Gaëtan
Gaëtan PERRIER (04/03/2015, 02h30)
Le Tue, 3 Mar 2015 01:01:17 +0100
Gaëtan PERRIER <gaetan.perrier> a écrit:

[..]
> error: Unable to locate device hpaio:/net/ENVY_7640_series?ip=192.168.1..81
> using SANE backend hpaio:. Please check HPLIP installation.
> Je ne sais pas quoi vérifier et où vérifier dans mon installation hplip ?


J'ai fait un hp-check qui ne révèle rien d'anormal mis à part un problème sur
un truc optionnel :
error: reportlab Reportlab - PDF library for
Python OPTIONAL 2.0
3.1.8 MISSING 'reportlab needs to be installed'

il dit MISSING alors qu'il voit la version 3.1.8 ... Mais bon c'est optionnel.

Gaëtan
Gaëtan PERRIER (04/03/2015, 03h40)
Le Wed, 4 Mar 2015 01:23:38 +0100
Gaëtan PERRIER <gaetan.perrier> a écrit:

> Le Tue, 3 Mar 2015 01:01:17 +0100
> Gaëtan PERRIER <gaetan.perrier> a écrit:
> J'ai fait un hp-check qui ne révèle rien d'anormal mis à part un problème sur
> un truc optionnel :
> error: reportlab Reportlab - PDF library for
> Python OPTIONAL 2.0
> 3.1.8 MISSING 'reportlab needs to be installed'
> il dit MISSING alors qu'il voit la version 3.1.8 ... Mais bon c'est
> optionnel.


Ça y est ça fonctionne ! Le truc c'est que dans la procédure d'installation
manuelle quand on est en jessie ou sid il faut faire comme pour du 32 bits
même si on est sur une machine 64 bits. Sinon il va mettre les lib
dans /usr/lib64.
Un autre truc si on utilise checkinstall c'est que pour que ça fonctionneil
faut que le paquet hplip-data soit installé sinon il n'arrive pas à
créer /usr/share/hplip/data mais ensuite l'installation automatique du paquet
à la fin de checkinstall échoue car il est en conflit avec hplip-data (ou
alors faire un checkinstall --install=no). Il faut donc retirer hplip-data et
ensuite installer le paquet hplip 3.15.2 avec dpkg -i.

Gaëtan
Gaëtan PERRIER (18/04/2015, 13h50)
Le Sat, 21 Feb 2015 00:41:54 +0100
Gaëtan PERRIER <gaetan.perrier> a écrit:

> Bonjour,
> La version d'hplip dans debian date d'il y a plus de 8 mois
> (3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si
> longue. Du coup nombre d'imprimantes en vente actuellement nécessite au
> moins la version 3.14.10.
> Je me demande donc si quelqu'un a déjà installer hplip depuis le wizard du
> site ? Est-ce ça pose des problèmes ?
> Gaëtan


Bonjour,

Je reviens sur le sujet car je viens d'aller voir sur le site
et quand je sélectionne mon imprimante (HP Envy
7640) et Debian 8 ça me dit que hplip 3.15.2 est déjà dans debian 8 ("Debian
8.0 supplies HPLIP 3.15.2 and it does support your printer.") et que donc il me
suffit d'installer les paquets debian. Sauf que hplip n'est pas dans debian8
ni même dans debian toutes versions confondues. Ils picolent trop chez HP?

Gaëtan
nicolas.patrois (18/04/2015, 14h20)
Le 18/04/2015 13:46:43, Gaëtan PERRIER a écrit :

> Je reviens sur le sujet car je viens d'aller voir sur le site
> et quand je sélectionne mon imprimante
> (HP Envy 7640) et Debian 8 ça me dit que hplip 3.15.2 est déjà dans
> debian 8 ("Debian 8.0 supplies HPLIP 3.15.2 and it does support your
> printer.") et que donc il me suffit d'installer les paquets debian.
> Sauf que hplip n'est pas dans debian 8 ni même dans debian toutes
> versions confondues. Ils picolent trop chez HP ?


Wabon ?

> aptitude show hplip

Paquet : hplip
Nouveau: oui
État: installé
Automatiquement installé: oui
Version : 3.14.6-1+b2
Priorité : optionnel
Section : utils
Responsable : Debian HPIJS and HPLIP maintainers <pkg-hpijs-
devel>
[?]

nicolas patrois : pts noir asocial
Discussions similaires