gratifiant > linux.debian.user.french

JUPIN Alain (26/04/2019, 08h30)
Bonjour,

Bon je sais que cela va être un peu HS car il s'agit d'une problème sous
Ubuntu 18.04 LTS (mais basée sur Debian). N'ayant pu trouver de
solutions sur les forums dédiés à Ubuntu je tente ma chance ici !

J'ai depuis de nombreuses années TeamSpeak 3 d'installer sur ma machine
sans aucun soucis. Mais cette semaine, suite à sa mise à jour (de TS3
voire de l'OS lui-même), je n'arrive plus à démarrer ce dernier. J'ai le
message d'erreur suivant :

|Échec du chargement de certificats d?autorité de certification !
Veuillez installer des certificats d?autorité de certification sur votre
système ou indiquer l?emplacement en utilisant la variable
d?environnement SSL_CERT_DIR ou SSL_CERT_FILE.|

Pourtant, ca-certificates est bien installé dans sa dernière version,
donc à jour !

|$ sudo dpkg -l | grep ca-certificates ii ca-certificates 20180409 all
Common CA certificates ii ca-certificates-java 20180516ubuntu1~18.04.1
all Common CA certificates (JKS keystore) ii ca-certificates-mono
4.6.2.7+dfsg-1ubuntu1 all Common CA certificates (Mono keystore)|

Dans le script de lancement de TeamSpeak, j'ai rajouté les lignes
suivantes (juste au dessus du lancement de teamspeak)

|export SSL_CERT_DIR="/etc/ssl/certs/" export
SSL_CERT_FILE="/etc/ssl/certs/ca-certificates.crt"|

Cela ne résout pas le problème, j'ai tenté de faire la même manip dans
le terminal, puis lancer le script de lancement de TS3, idem toujours le
même message.
Idem en ne mettant qu'une l'une ou l'autre des deux lignes précédemment
citées.

Comme il me semblait que cela venait d'une mise à jour de TS3, j'ai donc
essayer une version plus vieille (3.2.3 mais aussi 3.1.6) et dans les
deux cas, je me retrouve avec le même problème que celui cité plus haut !

PS : J'ai bien vu cette discussion : [résolu] certificats pour
TeamSpeak3 sous Ubuntu (Xubuntu) 18.04 LTS
<https://forum.ubuntu-fr.org/viewtopic.php?id=2036347>, mais la solution
apportée ne fonctionne pas chez moi  !

Merci à vous si certains ont des idées et désolé pour le HS
Sébastien Dinot (26/04/2019, 08h50)
JUPIN Alain a écrit :
> ca-certificates 20180409


Je ne connais pas TeamSpeak, mais le paquet ca-certificates me semble un
peu vieux. Sur mon système (Debian Buster), le numéro de version est
20190110. Ceci explique peut-être cela.

Pour en avoir le c?ur net, il faudrait récupérer le certificat TLS/SSL
de TeamSpeak, regarder quelle autorité l'a généré et voir si ce
certificat de cette autorité est fourni par le paquet ca-certificates
20180409.

Sinon, tu peux aussi tenter de regénérer le fichier
/etc/ssl/certs/ca-certificates.crt via la commande :

sudo update-ca-certificates -f

Sébastien
Discussions similaires