gratifiant > comp.os.* > comp.os.linux.configuration

Christophe PEREZ (31/05/2005, 20h07)
Bonjour,

Depuis que j'ai ma carte sb live 5.1, j'ai souvent fait des tentatives
d'utilisation d'alsa qui se sont toujours soldées par des échecs vu la
qualité obtenues par rapport à ce que j'ai avec oss.

Hier, je me suis rendu compte que par je ne sais quel mécanisme subtil,
avec mon oss, sous Teampeak, mon correspondant reçoit aussi tout ce qui
vient de ma carte son (bruitage jeu, retour de ce qu'il dit etc...) et
pourtant, je fonctionne avec un casque et micro.

Après avoir passé des heures à tenter de solutionner ce problème en
vain, j'ai décidé de retenter l'aventure alsa.
Recompilation noyau (sous gentoo), installation des packages nécessaires,
configuration modules etc...
Et une fois de plus, je me retrouve avec un son moins bon qu'avec oss. Le
son est moins clair, je ne peux pas pousser les aigus sinon ça crache, je
ne peux pas monter le PCM sinon saturation, impossibilité de régler les
volumes des enceintes arrières (kit 5.1 altec lansing), du central...,
et, en mettant mon ampli en 5.1, aucun son dans les enceintes arrières,
dans le central et dans le caisson de basses.

Avec oss, j'avais du magouiller pour avoir le bon résultat en
récupérant les binaires du packages emu10k1-tools de mandrake, et en
configurant aux petits oignons le /etc/emu10k1.conf.

Alors, ma question c'est principalement :
Y a t'il quelqu'un qui possède ce genre de carte ici, qui pourrait m'en
donner sa config précise ?
Et y a t'il des outils comme les emutools permettant de faire ce
paramètrage fin qui semble me manquer cruellement ?

Merci d'avance.
Christophe PEREZ (31/05/2005, 20h16)
Le Tue, 31 May 2005 14:07:01 -0400, Christophe PEREZ a écrit:

> Avec oss, j'avais du magouiller pour avoir le bon résultat en
> récupérant les binaires du packages emu10k1-tools de mandrake, et en
> configurant aux petits oignons le /etc/emu10k1.conf. [...]
> Et y a t'il des outils comme les emutools permettant de faire ce
> paramètrage fin qui semble me manquer cruellement ?


Je viens de retrouver le package emu10k1 sous gentoo, et de comprendre que
pour l'installer il faut le démasquer pour un noyau 2.6.x sinon il ne
s'installe pas, mais le pb c'est que c'est bien le package pour gestion
avec OSS et pas ALSA.
Christophe PEREZ (03/06/2005, 03h28)
Le Tue, 31 May 2005 14:07:01 -0400, Christophe PEREZ a écrit:

> Y a t'il quelqu'un qui possède ce genre de carte ici, qui pourrait m'en
> donner sa config précise ?


Ben voilà !
Ça démontre quand même une fois de plus que le problème n'est pas si
facilement réglé comme certains aiment à me le dire.

Après donc un n-ième tentative alsa, je reviens à OSS, en espérant que
celui-ci ne sera pas retiré avant que j'ai changé de carte son.

D'autant que j'ai trouvé, un peu par hasard, pourquoi j'avais un retour
son avec OSS dans TeamSpeak.
Tout simplement à cause de l'enregistrement activé sur Igain, et que
j'ai placé sur Mic. Or, j'ai toujours tourné avant avec ce réglage là,
et sans echo. Quelque chose a du évoluer récemment.
Pour être précis, voici ce que donne mon /etc/.aumixrc :
mic:0:0:R
igain:1:1:P (si 0, pas de son enregistré, et plus j'augmente, plus il y a
de bruit de fond)

Merci pour votre attention ;-)
Khanh-Dang (03/06/2005, 10h13)
Christophe PEREZ a écrit :
> Et une fois de plus, je me retrouve avec un son moins bon qu'avec oss.


Hmmm. En ce qui me concerne, avec une SB Live 5.1, il ne faut pas faire
monter le volume du canal nommé PCM à plus de 71 % (l'indicateur de
alsamixer ne doit pas virer au rouge). Car au delà de ces 71%, le son
est amplifié logiciellement, d'où la distorsion.
Christophe PEREZ (03/06/2005, 19h11)
Le Fri, 03 Jun 2005 10:13:02 +0200, Khanh-Dang a écrit:

> Hmmm. En ce qui me concerne, avec une SB Live 5.1, il ne faut pas faire
> monter le volume du canal nommé PCM à plus de 71 % (l'indicateur de
> alsamixer ne doit pas virer au rouge). Car au delà de ces 71%, le son
> est amplifié logiciellement, d'où la distorsion.


Oui, je m'en suis effectivement rendu compte, et pareil pour le PCM2, mais
malgré tout, la qualité de sortie est loin de valoir celle de OSS, bien
que tout à fait correcte.
Mais avec OSS, j'ai un tel son à couper le souffle avec mon kit
d'enceintes 5.1 que j'en suis devenu difficile. Sur un autre machine, je
ne sentirais probablement pas la différence.
As-tu déjà essayé ta carte avec OSS pur ?
Khanh-Dang (04/06/2005, 11h09)
Christophe PEREZ a écrit :
> Mais avec OSS, j'ai un tel son à couper le souffle avec mon kit
> d'enceintes 5.1 que j'en suis devenu difficile.


Je n'écoute pas beaucoup de musique ni ne regarde de films sur mon
ordinateur utilisé quotidiennement, donc je ne saurais confirmer ton
appréciation.

Mais à mon avis, ce n'est pas forcément que OSS est meilleur que alsa
pour la carte SBLive 5.1. Ce sont aussi et peut-être surtout les
réglages par défaut de alsa qui ne sont pas adaptés. Il faut avouer que
le réglage d'une telle carte semble compliqué, et malheureusement pas du
tout documenté, ou en tout cas très peu.

Il y a quelques éléments intéressants ici :
<http://linuxfr.org/comments/310935.html#310935>
Christophe PEREZ (04/06/2005, 18h20)
Le Sat, 04 Jun 2005 11:09:23 +0200, Khanh-Dang a écrit:

> Je n'écoute pas beaucoup de musique ni ne regarde de films sur mon
> ordinateur utilisé quotidiennement, donc je ne saurais confirmer ton
> appréciation.


Ah oui, et bien effectivement, c'est ce que je disais, pour un usage
classique du son, alsa dans les conditions où je l'ai peut parfaitement
suffire.

> Mais à mon avis, ce n'est pas forcément que OSS est meilleur que alsa
> pour la carte SBLive 5.1. Ce sont aussi et peut-être surtout les
> réglages par défaut de alsa qui ne sont pas adaptés.


Fort possible, oui.

> Il faut avouer que
> le réglage d'une telle carte semble compliqué,


Le mot est faible, c'est absolument introuvable, d'où ma question
initiale, de trouver quelqu'un qui ait les mêmes exigences que moi, avec
la même carte, et un config alsa tout à fait satisfaisante, pour la
repomper honteusement ;-)

> et malheureusement pas du
> tout documenté, ou en tout cas très peu.
> Il y a quelques éléments intéressants ici :
> <http://linuxfr.org/comments/310935.html#310935>


Vais voir ça, merci.
Christophe PEREZ (04/06/2005, 18h31)
Le Sat, 04 Jun 2005 11:09:23 +0200, Khanh-Dang a écrit:

> Il y a quelques éléments intéressants ici :
> <http://linuxfr.org/comments/310935.html#310935>


Oh oui !
Déjà quand je lis ça :
"Je trouve que, tels qu'implémentés, les basses et les aigüs sont
pourris avec le pilote ALSA ; il faudrait améliorer le code EMU10K1 qui
les gère"

Comme quoi, il n'y a pas que mon oreille qui le sente.

et ça :
"Avec le bon vieux OSS et un emuscript bien placé, le volume "Pcm" change
arrière comme avant"

montre que je ne suis pas le seul à avoir été satisfait de OSS avec
cette carte.

et ça :
"Je pense qu'au fur et à mesure que les gens vont passer à ALSA, il y
aura une pression grandissante pour améliorer la situation."

écrit en 2003 aurait pu laisser de l'espoir si nous n'étions déjà en
2005 sans notable amélioration...

Ceci dit, merci pour ce lien qui m'a permis de beaucoup mieux cerner
certaines choses.
Discussions similaires