gratifiant > linux.debian.user.french

BERTRAND Joël (14/10/2019, 14h50)
Bonjour à tous,

J'utilise un player diskless qui tourne sous debian/stable. Pour je ne
sais plus quelle raison (sans doute un codec qui ne fonctionnait pas
correctement), j'ai fait un apt dist-upgrade. kde est passé de la
version 4 à la version 5 (j'utilise KDE sur cette machine car c'est le
seul qui est capable de gérer correctement la sortie son HDMI en étant
'Michu compliant'). kdm n'étant plus supporté, j'ai installé et
configuré sddm à la place (franchement, quelle idée d'avoir les logins
disponibles sur la page de connexion...).

Depuis, pulseaudio refuse de démarrer (quel que soit l'utilisateur). Si
j'ouvre un xterm et que je tape pulseaudio --start, tout rentre dans
l'ordre.

L'ennui, dans le bazar kde, c'est que je ne vois pas qui doit lancer
pulseaudio et j'aimerais assez éviter une rustine consistant à modifier
les fichiers de conf de chaque utilisateur pour qu'en cas de connexion à
kde sur cette machine, pulseaudio soit bien démarré.

Une idée ?

Bien cordialement,

JKB
Bureau LxVx (14/10/2019, 17h30)
Bonjour à tous,

Un de nos adhérents Linux Ventoux a eu le même problème : le passage au
nouveau noyau ...

Bien librement,

Sylvie

Le 14/10/2019 à 14:32, BERTRAND Joël a écrit :
[..]
BERTRAND Joël (14/10/2019, 18h00)
Bureau LxVx a écrit :
> Bonjour à tous,
> Un de nos adhérents Linux Ventoux a eu le même problème : le passage au
> nouveau noyau ...


Je ne vois pas bien le rapport. Si c'était un problème de noyau, je ne
pourrais pas le lancer dans un terminal. Pour moi, ça vient plutôt d'un
problème quelque part dans la grouille KDE.

Bien cordialement,

JKB
Raphaël POITEVIN (14/10/2019, 21h00)
Bonsoir,

BERTRAND Joël <joel.bertrand> writes:
> Depuis, pulseaudio refuse de démarrer (quel que soit l'utilisateur).. Si
> j'ouvre un xterm et que je tape pulseaudio --start, tout rentre dans
> l'ordre.
> L'ennui, dans le bazar kde, c'est que je ne vois pas qui doit lancer
> pulseaudio et j'aimerais assez éviter une rustine consistant à modifier
> les fichiers de conf de chaque utilisateur pour qu'en cas de connexion à
> kde sur cette machine, pulseaudio soit bien démarré.


Avant de lancer pulse idiot à la main, voir si déjà une instance est en
mémoire :
ps aux | grep pulseaudio

Est-ce que dans /etc/pulse/client.conf :
autospawn = yes

/etc/pulse/daemon.conf :
system-instance = no
BERTRAND Joël (14/10/2019, 21h10)
Raphaël POITEVIN a écrit :
> Bonsoir,
> BERTRAND Joël <joel.bertrand> writes:
> Avant de lancer pulse idiot à la main, voir si déjà une instance est en
> mémoire :
> ps aux | grep pulseaudio
> Est-ce que dans /etc/pulse/client.conf :
> autospawn = yes


Non, la ligne est commentée (j'ai la configuration par défaut, je n'ai
jamais touché à ce fichier).

> /etc/pulse/daemon.conf :
> system-instance = no


Pareil, ligne commentée.

Je vais donc tester en modifiant ces deux fichiers.

Merci pour l'indication.

JKB
BERTRAND Joël (15/10/2019, 18h40)
BERTRAND Joël a écrit :
> Raphaël POITEVIN a écrit :
> Non, la ligne est commentée (j'ai la configuration par défaut, je n'ai
> jamais touché à ce fichier).
> Pareil, ligne commentée.
> Je vais donc tester en modifiant ces deux fichiers.
> Merci pour l'indication.
> JKB


Testé. Rien à faire, puseaudio ne démarre pas...

JKB
Sébastien NOBILI (18/10/2019, 14h50)
Bonjour,

15 octobre 2019 18:35 "BERTRAND Joël" <joel.bertrand> a écrit:

> Testé. Rien à faire, puseaudione démarre pas...


Chez moi, PulseAudio est démarré via Systemd en mode utilisateur (/usr/lib/systemd/user/pulseaudio.service)..

N'aurais-tu pas un autre système d'init actif à la placede Systemd ou désactivé l'unité pulseaudio.service ?

Sébastien
Discussions similaires