gratifiant > linux.debian.user.french

garfield (11/09/2005, 01h10)
Bonsoir la liste,

J'ai le probleme suivant lorsque j'essaye de compiler un kernel debian à
la sauce debian.

{entrée standard}: Message de l'assembleur:
{entrée standard}: suffixe ou opérande invalide pour "mov"

Une idée ?
Merci.
Alain Dawson (11/09/2005, 16h40)
> Bonsoir la liste,
> J'ai le probleme suivant lorsque j'essaye de compiler un kernel debian à la sauce debian.
> {entrée standard}: Message de l'assembleur:
> {entrée standard}: suffixe ou opérande invalide pour "mov"
> Une idée ?


Pas d'idée mais j'ai le même pb... ma dernière compilation il y a un
mois s'était passée normalement...
Jean-Luc Coulon (f5ibh) (11/09/2005, 17h10)
Le 11.09.2005 16:21:52, Alain Dawson a écrit :
> > Bonsoir la liste,
> > J'ai le probleme suivant lorsque j'essaye de compiler un kernel

> debian à la sauce debian.
> > {entrée standard}: Message de l'assembleur:
> > {entrée standard}: suffixe ou opérande invalide pour "mov"
> > Une idée ?


Quelle version de noyau, quelle version de compilateur ?
Gurvan Huiban (11/09/2005, 17h20)
On Sunday 11 September 2005 16:21, Alain Dawson wrote:
> debian à la sauce debian.
> Pas d'idée mais j'ai le même pb... ma dernière compilation il y a un
> mois s'était passée normalement...


Un noyau qui ne compile pas avec gcc-4??
Alain Dawson (11/09/2005, 17h50)
Jean-Luc Coulon (f5ibh) a écrit :
> Le 11.09.2005 16:21:52, Alain Dawson a écrit :
> Quelle version de noyau, quelle version de compilateur ?


en ce qui me concerne :
gcc version 4.0.2 20050821 (prerelease) (Debian 4.0.1-6)
noyau 2.6.11
Simon BZ (11/09/2005, 18h20)
On 9/11/05, Alain Dawson <a.dawson> wrote:
> Jean-Luc Coulon (f5ibh) a écrit :
> en ce qui me concerne :
> gcc version 4.0.2 20050821 (prerelease) (Debian 4.0.1-6)
> noyau 2.6.11

Pour ma part, j'ai eu des erreurs de compilations avec gcc-4.0 lors
de la mise à jour au kernel 2.6.12 ...

tu pourrais essayer gcc-3.3 ou gcc-3.4 à la place
Alain Dawson (11/09/2005, 19h20)
Simon BZ a écrit :
> On 9/11/05, *Alain Dawson* <a.dawson <mailto:a.dawson>>
> wrote:
> Jean-Luc Coulon (f5ibh) a écrit :
> a un
> en ce qui me concerne :
> gcc version 4.0.2 20050821 (prerelease) (Debian 4.0.1-6)
> noyau 2.6.11
> Pour ma part, j'ai eu des erreurs de compilations avec gcc-4.0 lors
> de la mise à jour au kernel 2.6.12 ...
> tu pourrais essayer gcc-3.3 ou gcc-3.4 à la place


Question bête, sans doute : comment on sélectionne la version de gcc
avec make-kpkg ?
Jean-Luc Coulon (f5ibh) (11/09/2005, 19h30)
Le 11.09.2005 19:00:01, Alain Dawson a écrit :
>> tu pourrais essayer gcc-3.3 ou gcc-3.4 à la place

> Question bête, sans doute : comment on sélectionne la version de gcc
> avec make-kpkg ?


MAKEFLAGS="CC=gcc-3.4" make-kpkd <lesoption kivonbien>

man make-kpkg(1) pour plsu d'informations
garfield (11/09/2005, 19h30)
Alain Dawson a écrit :
[..]
Alain Dawson (11/09/2005, 20h00)
Jean-Luc Coulon (f5ibh) a écrit :
> Le 11.09.2005 19:00:01, Alain Dawson a écrit :
> MAKEFLAGS="CC=gcc-3.4" make-kpkd <lesoption kivonbien>
> man make-kpkg(1) pour plsu d'informations
> Jean-Luc


Merci. Hélas, gcc-3.3 ne change rien au problème...
Alain
Discussions similaires