gratifiant > linux.debian.user.french

tonyaccardo (08/11/2004, 19h00)
Bonjour à tous,
Après avoir développé un site web en php4 sur mon pc portable (avec
easyphp), j'ai voulu le migrer sur un serveur debian sarge, pour que mes
utilisateurs puissent le tester....
Résultat : Warning: mysql_fetch_row(): supplied argument is not a valid
MySQL result resource in ....
Après avoir pas mal cherché, et bidouillé le code pour voir d'ou cela
pouvait venir, et pour en avoir le coeur net, j'ai essayé d'installer
mon site sur un serveur debian woody.... et oh, surprise, tout
fonctionne à merveille....
Le hic, c'est que le serveur debian woody est mon serveur de production,
et j'aimerais bien que mes utilisateurs puissent passer un moment à
tester l'appli "à blanc"...
J'ai bien vérifié la liste des paquets de part et d'autres, mais rien ne
me saute aux yeux...
Est ce que quelqu'un saurait d'ou peut venir le pbm?
A+
Tony
Guillaume Duveau (08/11/2004, 22h00)
> Est ce que quelqu'un saurait d'ou peut venir le pbm?

Est-ce que tu as aussi des erreurs de unknown variable ? Si oui ça vient
de la désactivation de register_globals par défaut depuis PHP 4.3.5 je
crois (Sarge : PHP 4.3.9-1). Quelle version de EasyPHP tu as sur ton
portable ?

A ce moment les variables PHP que tu utilises pour créer ta requête sont
vides d'où le mysql_fetch_row(): supplied argument is not a valid MySQL
tonyaccardo (09/11/2004, 18h50)
Bonjour à tous,
en fait, il s'agissait simplement d'un pbm de connexion sur ma machine
d'indus....
pardon pour le derangement.
A+
Tony

-----Message d'origine-----
De : tonyaccardo [mailto:tonyaccardo]
Envoyé : lundi 8 novembre 2004 17:52
À : debian-user-french
Objet : PHP4 & Sarge

Bonjour à tous,
Après avoir développé un site web en php4 sur mon pc portable (avec
easyphp), j'ai voulu le migrer sur un serveur debian sarge, pour que mes
utilisateurs puissent le tester....
Résultat : Warning: mysql_fetch_row(): supplied argument is not a valid
MySQL result resource in ....
Après avoir pas mal cherché, et bidouillé le code pour voir d'ou cela
pouvait venir, et pour en avoir le coeur net, j'ai essayé d'installer
mon site sur un serveur debian woody.... et oh, surprise, tout
fonctionne à merveille....
Le hic, c'est que le serveur debian woody est mon serveur de production,
et j'aimerais bien que mes utilisateurs puissent passer un moment à
tester l'appli "à blanc"...
J'ai bien vérifié la liste des paquets de part et d'autres, mais rien ne
me saute aux yeux...
Est ce que quelqu'un saurait d'ou peut venir le pbm?
A+
Tony
Discussions similaires