gratifiant > linux.debian.user.french

GRAVIER Olivier URS Noisy (02/07/2004, 12h30)
Bonjour,

je viens d'installer une debian sur une sparc sattion 20, et je n'arrive pas a mettre en place mon interface graphique X.
voici les logs :
************************************************** ****************
warning: process set to nice value 0 instead of -10 as requested

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86 and patches submitted
to fixes. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
()

XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See )
Build Operating System: Linux 2.4.24 sparc [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Fri Jul 2 13:07:47 2004
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "sun"
(**) | |-->Device "sun"
(**) |-->Input Device "Generic Keyboard"
(**) XKB: rules: "xfree86"
(**) XKB: model: "type5"
(**) XKB: layout: "fr"
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "Generic Mouse"
(WW) No FontPath specified. Using compiled-in default.
(WW) The directory "/usr/X11R6/lib/X11/fonts/CID/" does not exist.
Entry deleted from font path.
(==) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib
/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 8

(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
(EE) No OS PCI support available
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.1.9
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libpex5.a
(II) Module pex5: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.13.0
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libxie.a
(II) Module xie: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/drivers/suntcx_drv.o
(II) Module suntcx: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) SUNTCX: driver for TCX
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit.

X connection to :0.0 broken (explicit kill or server shutdown).

************************************************** ****************

voici dmesg :

************************************************** ****************
PROMLIB: Sun Boot Prom Version 3 Revision 2
Linux version 2.2.20 (root@auric) (gcc version 2.95.2 20000220 (Debian GNU/Linux)) #1 Fri Nov 16 15:48:02 EST 2001
ARCH: SUN4M
TYPE: Sun4m SparcStation10/20
Ethernet address: 8:0:20:77:e1:8d
Boot time fixup v1.6. 4/Mar/98 Jakub Jelinek (jj). Patching kernel for srmmu[TI Viking/MXCC]/iommu
[0]: v[f0000000,f1000000](1000000) p[00000000]
[1]: v[f1000000,f2000000](1000000) p[02000000]
[2]: v[f2000000,f3000000](1000000) p[08000000]
[3]: v[f3000000,f4000000](1000000) p[0a000000]
[4]: v[f4000000,f7f4f000](3f4f000) p[14000000]
Found CPU 0 <node=ffd6f150,mid=8>
Found 1 CPU prom device tree node(s).
Power off control detected.
Console: colour dummy device 80x25
Calibrating delay loop... 74.75 BogoMIPS
Memory: 125496k available (1340k kernel code, 3360k data, 168k init) [f0000000,f8000000]
Dentry hash table entries: 16384 (order 5, 128k)
Buffer cache hash table entries: 131072 (order 7, 512k)
Page cache hash table entries: 32768 (order 5, 128k)
POSIX conformance testing by UNIFIX
IOMMU: impl 1 vers 3 page table at f7e40000 of size 262144 bytes
sbus0: Clock 25.0 MHz
dma0: Revision 2
dma1: Revision 2
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 131072 bhash 65536)
Linux IP multicast router 0.06 plus PIM-SM
Starting kswapd v 1.5
Console: switching to colour frame buffer device 128x54
fb0: cgsix at e.20000000 TEC Rev 4 CPU sparc Rev b [TurboGX]
Sparc Zilog8530 serial driver version 1.41.2.9
tty00 at 0xffede004 (irq = 44) is a Zilog8530
tty01 at 0xffede000 (irq = 44) is a Zilog8530
tty02 at 0xffedb004 (irq = 44) is a Zilog8530
tty03 at 0xffedb000 (irq = 44) is a Zilog8530
Sun TYPE 5 keyboard detected without keyclick
pty: 256 Unix98 ptys configured
Sun Mouse-Systems mouse driver version 1.00
RAM disk driver initialized: 16 RAM disks of 4096K size
loop: registered device at major 7
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
esp0: IRQ 36 SCSI ID 7 Clk 40MHz CCF=8 TOut 167 NCR53C9XF(espfast)
ESP: Total of 1 ESP hosts found, 1 actually in use.
scsi0 : Sparc ESP100A-FAST
scsi : 1 host.
Vendor: CONNER Model: CFP1080E SUN1.05 Rev: 5150
Type: Direct-Access ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 1, lun 0
Vendor: CONNER Model: CFP1080E SUN1.05 Rev: 5150
Type: Direct-Access ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 3, lun 0
Vendor: SEAGATE Model: ST32430N SUN2.1G Rev: 0508
Type: Direct-Access ANSI SCSI revision: 02
Detected scsi disk sdc at scsi0, channel 0, id 5, lun 0
scsi : detected 3 SCSI disks total.
esp0: target 1 [period 100ns offset 15 10.00MHz FAST SCSI-II]
SCSI device sda: hdwr sector= 512 bytes. Sectors= 2110812 [1030 MB] [1.0 GB]
esp0: target 3 [period 100ns offset 15 10.00MHz FAST SCSI-II]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 2110812 [1030 MB] [1.0 GB]
esp0: target 5 [period 100ns offset 15 10.00MHz FAST SCSI-II]
SCSI device sdc: hdwr sector= 512 bytes. Sectors= 4197405 [2049 MB] [2.0 GB]
sunlance.c:v1.12 11/Mar/99 Miguel de Icaza (miguel)
eth0: LANCE 08:00:20:77:e1:8d
eth0: using auto-carrier-detection.
Partition check:
sda: sda1 sda2 sda3
sdb: sdb1 sdb2 sdb3
sdc: sdc1 sdc3
VFS: Mounted root (ext2 filesystem) readonly.
init[1]: Unimplemented SPARC system call 69
Adding Swap: 50896k swap-space (priority -1)
eth0: Carrier Lost, trying TPE
cp[120]: Unimplemented SPARC system call 69
mv[143]: Unimplemented SPARC system call 69
exim[168]: Unimplemented SPARC system call 69
exim[168]: Unimplemented SPARC system call 108
exim[168]: Unimplemented SPARC system call 110
nbd: registered device at major 43
sunmouse: Successfully adjusted to 1200 baud.
************************************************** ****************

si quelqu'un peut m'aider je serait bien content...

Olivier
Frédéric Bothamy (02/07/2004, 13h30)
* GRAVIER Olivier URS Noisy <olivier.gravier> [2004-07-02 12:10] :
> Bonjour,
> je viens d'installer une debian sur une sparc sattion 20, et je n'arrive pas a mettre en place mon interface graphique X.


[...]

> si quelqu'un peut m'aider je serait bien content...


Re-salut Olivier,

Tu as demandé sur debian-sparc comme je te l'avais conseillé
() ?

Fred
Jerome Chantelauze (02/07/2004, 14h20)
Bonjour

On Fri, Jul 02, 2004 at 12:10:05PM +0200, GRAVIER Olivier URS Noisy wrote:
> Bonjour,
> je viens d'installer une debian sur une sparc sattion 20, et je
> n'arrive pas a mettre en place mon interface graphique X.


Je dois me contenter d'une SS4 et d'une SS5, donc, je ne peux pas tester
ce que j'avance...

> voici les logs :
> ************************************************** ****************
> [...snip...]
> (II) SUNTCX: driver for TCX
> (EE) No devices detected.


Ton problème est là. Tu n'utilises pas le bon driver (carte graphique
non détectée). Le driver "suntcx" gère le frame buffer des cartes qui
équipent les SS4 et les SS5.

Les SS10 et SS20 disposent de cartes graphiques améliorées.

D'après ton dmesg, ta SS20 est équipée d'une carte Turbo GX. Elles sont
gérées par le driver "suncg6". Dans ton XF86Config-4, remplace "suntcx"
par "suncg6" et la carte graphique devrait être reconnue.

Sous réserve qu'il n'y ait pas d'autres problèmes, je pense que ça doit
marcher.

> si quelqu'un peut m'aider je serait bien content...


Voilà, j'espère t'avoir aider.
Discussions similaires