gratifiant > linux.debian.user.french

andre_debian (26/04/2015, 17h50)
On Sunday 26 April 2015 17:23:01 Nicolas FRANCOIS wrote:
> Le Sun, 26 Apr 2015 14:14:51 +0200,
> maderios <maderios> a écrit :
> > On 04/25/2015 10:38 PM, andre_debian wrote:
> > > Mieux vaut attendre un mois avant de migrer,
> > > comme pour les voitures neuves, faut pas acheter
> > > tout de suite, laissons les "cobayes" mariner... :-)



On Sunday 26 April 2015 16:57:40 andre_debian answers:
> J'en étais sûr qu'une susceptiblité déplacée, à côté de la plaque,
> allait tomber...
> J'avais pris soin de ponctuer mon mail d'un smiley :-),
> c'est à dire à prendre au second, voire troisième degré.
> Ça ne veut rien dire "un produit de consommation",
> si je m'adonne à la passion du vélo, je consomme
> des vélos et c'est une honte ?
> réaction aussi inutile qu'une baliverne qui cache je ne sais
> quelle besoin de revanche...
> André


> Bon, en tant que "cobaye", je veux ici confirmer que chez moi, en
> dehors de l'attente due à une connexion "paysanne", ça a marché au poil.
> Jusqu'à ce que je vous pose les premières questions, bien-sûr !


Le plus navrant est que je suis "cobaye" de Jessie depuis longtemps déjà...
sans avoir observé de problèmes.

André
Damien TOURDE (26/04/2015, 17h50)
Salut,

Je suis aussi passé de stable 7 à testing 8 il y a quelque mois sans
soucis majeur, à part la perte de ma session active (gnome 2), j'ai
juste eu à "finir" en TTY.

Je ne pense pas avoir loupé de config importante à ce moment, en tout
cas pas de soucis à ce jour.

Le 26/04/2015 17:38, maderios a écrit :
[..]
Damien TOURDE (26/04/2015, 19h20)
Le 26/04/2015 17:49, jbernon a écrit :
> Je viens de passer un vieux PC (AMD turion 64, 2GB mémoire totale, 1
> processeur 1600 MHz, 512 KB de cache) de Wheezy à Jessie. Tout semble
> fonctionner à part un bégaiement de la grille Gnome des applications
> (pas pratique mais cette grille n'est qu'un accessoire). Ni plus ni
> moins lent qu'avant. J'avais déjà installé Jessie en version testing sur
> un PC plus récent. Celui-ci va bien sûr beaucoup plus vite, mais j'ai au
> moins le cas d'une appli (Freetuxtv) qui marche avec Jessie sur le vieux
> PC et ne marche pas sur le récent. Curieux !


Tu peux jeter un coup d'?uil à VLC s'il fonctionne (notamment avec les
flux), car il me semble que freetuxtv se base sur VLC.
jbernon (26/04/2015, 20h00)
Je peux effectivement lire sur VLC les flux que je lis dans Freetuxtv. En revanche j'ai essayé d'autres uri de flux prises au hasard sur Internet(TF1 M6) et ça ne marche pas (erreur sur le codec Telex le plus souvent, mais pas seulement). Je ne peux guère t'en dire plus car personnellement j'utilise peu VLC et je ne l'utiliise en tous cas que pour lire des fichiers.

----- Mail original -----
[..]
Damien TOURDE (26/04/2015, 20h20)
Il me semble (depuis la Freebox tout du moins) que TF1 et M6 sont les
pires chaines pour les tests :-)

Freebox, on n'a pas le droit d'y accéder autrement que par la box,
après, y-a-t'il un moyen d'y accéder tout de même, je ne sais pas...

Le 26/04/2015 19:52, jbernon a écrit :
[..]
Alain Rpnpif (27/04/2015, 10h50)
Bonjour,

Le 26 avril 2015, maderios a écrit :

> Idem, d'ailleurs Testing marchait bien depuis un petit moment. Par
> ailleurs, il faut essayer et utiliser Sid, cela en vaut la peine.
> Sid est plus stable/fiable qu'Ubuntu, mais c'est un débat trollesque....


Mouais.
Par erreur, il y a 2 semaines, mon fils a mis à jour, sur une machine de
bureau, Wheezy avec sid et son systemd. Malheur lui en a pris, car plus
moyen de de connecter en Xorg.

Après tentative de remettre sysvinit, systemd a mis un de ces bazars
tel que seul la console de maintenance fonctionnait. Il semble que
systemd avec Xorg n'aime pas du tout le changement de libc6.

Après 2 ou 3 heures de travail, tout est revenu dans l'ordre.

Donc je resterai sous Wheezy et ses backports qui fonctionne très bien
et est rapide.

Je sais que sysvinit est utilisable dans Jessie, mais savez-vous s'il
est possible de migrer vers Jessie en évitant toute trace de Systemd et
donc de ses effets pervers, en interdisant **dès le départ**
l'installation de systemd et ou de ses fichiers de configuration
inutiles dans ce cas ?
BERTRAND Joël (27/04/2015, 12h00)
Alain Rpnpif a écrit :
[..]
> donc de ses effets pervers, en interdisant **dès le départ**
> l'installation de systemd et ou de ses fichiers de configuration
> inutiles dans ce cas ?


Bonjour,

Personnellement, je n'ai pas trouvé. Et si tu as la solution, elle
m'intéresse. J'ai un serveur de test sous Jessie et l'inénarrable
systemd. Outre le fait qu'un apt-get update qui installe une nouvelle
version de systemd oblige à rebooter (sous peine de voire le machin
dysfonctionner, même des trucs simples comme le serveur NFS), certains
daemons ne se lancent au boot qu'aléatoirement (je pense aux reègles
iptables). Bref, systemd n'est vraiment pas sec et son fonctionnement
n'est pas reproductible.

J'avais un sale a priori dès le départ du fait de sa conception. Mais
plus je l'utilise et pire je le trouve.

JKB
JF Straeten (27/04/2015, 14h10)
LO,

On Mon, Apr 27, 2015 at 10:41:19AM +0200, Alain Rpnpif wrote:

[...]
> Je sais que sysvinit est utilisable dans Jessie, mais savez-vous
> s'il est possible de migrer vers Jessie en évitant toute trace de
> Systemd et donc de ses effets pervers, en interdisant **dès le
> départ** l'installation de systemd et ou de ses fichiers de
> configuration inutiles dans ce cas ?


On Mon, Apr 27, 2015 at 11:52:40AM +0200, BERTRAND Joël wrote:

[...]
> Personnellement, je n'ai pas trouvé. Et si tu as la solution, elle
> m'intéresse.


Avez-vous essayé l'installation de file-rc ? (Il est décrit comme
« Alternative boot mechanism using a single configuration file »).

Il faut un peu insister car il remplace sysvinit et/ou systemd,
paquets essentiels, mais sur le principe, ça marche : je l'ai fait ici
sous Jessie.

(Et entre parenthèses, la config est bien plus simple que la grosse
soupe aux symlinks...)

Hih,
maderios (27/04/2015, 14h10)
On 04/27/2015 10:41 AM, Alain Rpnpif wrote:
> Bonjour,
> Le 26 avril 2015, maderios a écrit :
>> Idem, d'ailleurs Testing marchait bien depuis un petit moment. Par
>> ailleurs, il faut essayer et utiliser Sid, cela en vaut la peine.
>> Sid est plus stable/fiable qu'Ubuntu, mais c'est un débat trollesque...

> Mouais.


Bonjour

> Par erreur, il y a 2 semaines, mon fils a mis à jour, sur une machine de
> bureau, Wheezy avec sid et son systemd. Malheur lui en a pris, car plus
> moyen de de connecter en Xorg.
> Après tentative de remettre sysvinit, systemd a mis un de ces bazars
> tel que seul la console de maintenance fonctionnait. Il semble que
> systemd avec Xorg n'aime pas du tout le changement de libc6.
> Après 2 ou 3 heures de travail, tout est revenu dans l'ordre.

En 2015, passer sans transition de Wheezy à Sid, cela représente un saut
dans l'espace-temps considérable. Il est donc logique qu'il faille
revoir certaines configurations, il est même étonnant que cela se passe
si bien pour toi.
- J'utilise Sid pour travailler sur un PC, systemd marche bien et me
simplifie la vie par rapport à Sysvinit. Aucun souci ailleurs.
- J'utilise Jessie pour ménager un vieux (> 12 ans) portable poussif,
donc rares mises à jour, c'est l'intérêt de stable.
- J'ai réalisé tardivement que Testing n'est pas très sûr dans la mesure
où les maj de sécurité arrivent toujours très tard par rapport à Sid et
Stable.
contact (27/04/2015, 14h20)
moi j'ai commencer à tester debian 8 amd64 j'ai installer apache 2.4 et
php apache marche php marche pas je sais pas pourquois ...... je cherche
apt-get install apache2 php5

Le 27/04/2015 14:07, maderios a écrit :
[..]
Julien (27/04/2015, 14h40)
Bonjour,

As-tu activé le module php de apache ? :

a2enmod php

As-tu relancé apache ? ton fichier de test se trouve dans ton home ?

Julien

Le 27/04/2015 14:13, contact a écrit :
[..]
Sébastien NOBILI (27/04/2015, 15h10)
Le lundi 27 avril 2015 à 10:41, Alain Rpnpif a écrit :
> Je sais que sysvinit est utilisable dans Jessie, mais savez-vous s'il
> est possible de migrer vers Jessie en évitant toute trace de Systemd et
> donc de ses effets pervers, en interdisant **dès le départ**
> l'installation de systemd et ou de ses fichiers de configuration
> inutiles dans ce cas ?


C'est documenté dans les notes de publication. Je n'ai pas testé, je ne peux
donc pas affirmer qu'aucun fichier de configuration lié à Systemd ne sera
installé?



Sébastien
Erwan David (27/04/2015, 15h30)
On Mon, Apr 27, 2015 at 03:07:02PM CEST, Sébastien NOBILI <sebnewsletter> said:
> Le lundi 27 avril 2015 à 10:41, Alain Rpnpif a écrit :
> C'est documenté dans les notes de publication. Je n'ai pas testé, je ne peux
> donc pas affirmer qu'aucun fichier de configuration lié à Systemd ne sera
> installé?
>
> Sébastien


De fait un certain nombre de morceaux de systemd sont installés, nottament le paquet libsystemd0

Une jessie sans systemd n'est pas possible (au moins un paquet
"Essential" en dépend). Même si on peut ne pas en utiliser sa
compsante système d'init (car systemd cveut remplacer bien plus que le
système d'init).
andre_debian (27/04/2015, 15h40)
On Monday 27 April 2015 10:41:19 Alain Rpnpif wrote:
> Le 26 avril 2015, maderios a écrit :
> > Idem, d'ailleurs Testing marchait bien depuis un petit moment. Par
> > ailleurs, il faut essayer et utiliser Sid, cela en vaut la peine.
> > Sid est plus stable/fiable qu'Ubuntu, mais c'est un débat trollesque...


[..]
> donc de ses effets pervers, en interdisant **dès le départ**
> l'installation de systemd et ou de ses fichiers de configuration
> inutiles dans ce cas ? Alain Rpnpif


Désinstaller "systemd" pour "sysvinit" :


Je me suis donc mis "cobaye" (ou testeur) par une mise à jour de Wheezy
vers Jessie :-)
(l'autre était une nouvelle installation de Jessie, pas une mise à jour)

Sous Wheezy => apt-get-update | apt-get upgrade | apt-get dist-upgrade,
apt-get autoclean | apt-get autoremove,
afin d'avoir Wheezy propre.
Puis :
wheezy => jessie dans "sources.list , et :
apt-get-update | apt-get upgrade | apt-get dist-upgrade

Ce fut laborieux, très long, pas mal de messages d'erreur,
(impossible de les noter tant ils sont nombreux),
boot, reboot bloqués, réinstallation de grub...
enfin je peux booter en mode console.

Impossible de lancer le mode graphique que ce soit avec
lightdm, gdm3, tdm-trinity... + mot de passe non reconnu ensuite (quid ?)
Problème de PAM ?
Et miracle, enfin "tdm-trinity" se lance avec mot de passe accepté...
Aurais-je le même parcours du combattant lors du prochain boot ?

Ces difficultés viennent-elles de "systemd" et faut-il le désinstaller ?
(je n'ose le faire sans quelques avis...)

André
BERTRAND Joël (27/04/2015, 16h00)
andre_debian a écrit :
> Impossible de lancer le mode graphique que ce soit avec
> lightdm, gdm3, tdm-trinity... + mot de passe non reconnu ensuite (quid ?)
> Problème de PAM ?
> Et miracle, enfin "tdm-trinity" se lance avec mot de passe accepté...
> Aurais-je le même parcours du combattant lors du prochain boot ?
> Ces difficultés viennent-elles de "systemd" et faut-il le désinstaller ?
> (je n'ose le faire sans quelques avis...)


Difficile à dire comme ça. Je n'ai eu qu'un problème de configuration
de X avec systemd qui empêchait gdm3 ou kdm (je ne me souvient plus) de
démarrer. En revanche en console, un startx fonctionnait toujours. Je
n'ai jamais eu de problème d'authentification.

Mais j'ai de gros problèmes dans les dépendances des daemons sur mon
serveur de test.

Pour moi, le principal problème est surtout dans le fait que systemd
impose quasiment à chaque coup un reboot du serveur pour être sûr que
tout se passe correctement.

Cordialement,

JKB

Discussions similaires