gratifiant > linux.debian.user.french

ajh-valmer (11/11/2019, 20h30)
Bonsoir à tous,

J'ai migré de Stretch vers Buster.
Carte graphique Nvidia geforce proprio,
qui marchait parfaitement sous Stretch.

En rebootant, j'ai ce message d'erreur au début :
"Failed to start openIPMI driver init script".
(openIPMI est bien installé),
ainsi que linux-headers-4.19... et linux-image-4.19...

modprobe nvidia n'affiche pas d'erreur.

Si je lance X, l'écran devient noir, rien,
plus de clavier, bloqué, seule solution : hard reboot.

Merci d'une aide, une piste.

Bonne soirée,

A. Valmer
Daniel Huhardeaux (11/11/2019, 20h40)
Le 11/11/2019 à 19:24, ajh-valmer a écrit :
> Bonsoir à tous,


Bonsoir

> J'ai migré de Stretch vers Buster.
> Carte graphique Nvidia geforce proprio,
> qui marchait parfaitement sous Stretch.
> En rebootant, j'ai ce message d'erreur au début :
> "Failed to start openIPMI driver init script".
> (openIPMI est bien installé),
> ainsi que linux-headers-4.19... et linux-image-4.19...


Est ce un serveur ? As tu besoin de IPMI ? En tous cas rien à voir avec
ton problème.

> modprobe nvidia n'affiche pas d'erreur.
> Si je lance X, l'écran devient noir, rien,
> plus de clavier, bloqué, seule solution : hard reboot.


Connexion ssh possible ? Peux tu te connecter sur une console
(Ctrl+Alt+F1 à F6)
ajh-valmer (11/11/2019, 21h00)
> > J'ai migré de Stretch vers Buster.
> > Carte graphique Nvidia geforce proprio,
> > qui marchait parfaitement sous Stretch.
> > En rebootant, j'ai ce message d'erreur au début :
> > "Failed to start openIPMI driver init script".
> > (openIPMI est bien installé),
> > ainsi que linux-headers-4.19... et linux-image-4.19...


On Monday 11 November 2019 19:35:13 Daniel Huhardeaux wrote:
> Est ce un serveur ? As tu besoin de IPMI ?
> En tous cas rien à voir avec ton problème.


> Connexion ssh possible ? Peux tu te connecter sur une console
> (Ctrl+Alt+F1 à F6)


Comme je l'avais écrit :
> Si je lance X, l'écran devient noir, rien,
> plus de clavier, bloqué, seule solution : hard reboot.


Si je supprime /etc/X11/xorg.conf,
pas de mode graphique, mais je peux reprendre la main,
clavier fonctionnel, plus de blocage total.
Daniel Huhardeaux (12/11/2019, 10h30)
Le 11/11/2019 à 19:58, ajh-valmer a écrit :
[...]
>> Connexion ssh possible ? Peux tu te connecter sur une console
>> (Ctrl+Alt+F1 à F6)

> Comme je l'avais écrit :
>> Si je lance X, l'écran devient noir, rien,
>> plus de clavier, bloqué, seule solution : hard reboot.


Cela n'empêche pas ssh d'être fonctionnel ...
ajh-valmer (12/11/2019, 19h20)
On Monday 11 November 2019 19:58:14 ajh-valmer wrote:

> Pour l'installation des drivers sous stretch
>


Merci,
c'est pour Stretch, je suis maintenant sous Buster.
C'est depuis la migration, que X graphic (xorg) ne fonctionne plus.
Je n'avais rien touché à la config de Stretch.
Le noyau 4.19 ?

J'ai trouvé ce site :


Je lis : apt -y install nvidia-detect
mais "nvidia-detect" ne semble pas ou plus exister sous Buster.

Je suis toujours perdu... :-(

Bonne soirée.

A. Valmer
Maxime G. (12/11/2019, 20h10)
Bonjour.

Peut-être qu'un petit ménage s'impose avec:

apt update
apt purge nvidia*
rm /etc/X11/xorg.conf **(ou un move ailleurs pour sauvegarde car xorg se débrouille sans conf aujourd'hui)
reboot
apt install nvidia-detect
nvidia-detect
apt install nvidia-driver **(ou autre paquet annoncé par nvidia-detect)

Maxime.

12 novembre 2019 09:25 "Daniel Huhardeaux" <no-spam> a écrit:
[..]
lann (12/11/2019, 20h50)
Le Tue, 12 Nov 2019 18:14:08 +0100,
"ajh-valmer" <ajh.valmer> a écrit :

> On Monday 11 November 2019 19:58:14 ajh-valmer wrote:
> Merci,
> c'est pour Stretch, je suis maintenant sous Buster.
> C'est depuis la migration, que X graphic (xorg) ne fonctionne plus.
> Je n'avais rien touché à la config de Stretch.
> Le noyau 4.19 ?
> J'ai trouvé ce site :
>
> Je lis : apt -y install nvidia-detect
> mais "nvidia-detect" ne semble pas ou plus exister sous Buster.


apt-cache policy nvidia-detect
nvidia-detect:
Installé : 418.74-1
Candidat : 418.74-1
Table de version :
*** 418.74-1 990
990 stable/non-free amd64
Packages 100 /var/lib/dpkg/status

C'est dans les dépôts non-free
ajh-valmer (13/11/2019, 00h10)
On Tuesday 12 November 2019 19:45:49 lann wrote:
> "ajh-valmer" <ajh.valmer> a écrit :
> > On Monday 11 November 2019 ajh-valmer wrote:
> > > > > J'ai migré de Stretch vers Buster.
> > > > > Carte graphique Nvidia geforce proprio,
> > > > > qui marchait parfaitement sous Stretch.
> > > > > linux-headers-4.19... et linux-image-4.19.


> > > Pour l'installation des drivers sous stretch
> > >


> > J'ai trouvé ce site :>

>


> apt-cache policy nvidia-detect
> C'est dans les dépôts non-free


La carte est bien détectée.
Quelque soit le pilote choisi, pilote Free ou Non-Free.
pas de bureau graphique (Trinity-TDE).
Ni lightdm, ni tdm-trinity (gestionnaire de connexion) ne s'affichent.
S'agit-il de TDE qui ne s'accomode pas de Buster ?

Dernière nouvelle, en lançant X en mode console,
le bureau s'est lancé mais avec une résolution beaucoup trop faible,
et impossible de l'augmenter.

Y a bien sur la ML un inscrit qui est sous Buster et TDE ? :-)

Bonne nuit.
Support FoxServ (13/11/2019, 01h30)
Bonjour



Tu as était au bout du tutoriel ?

Gmone ou KDE ?

Voici un tutoriel complet sous Debian .



A +

-----Message d'origine-----
De : ajh-valmer <ajh.valmer>
Envoyé : mardi 12 novembre 2019 23:05
À : debian-user-french
Objet : Re: Migration Stretch vers Buster : plus de mode graphique

On Tuesday 12 November 2019 19:45:49 lann wrote:
> "ajh-valmer" <ajh.valmer> a écrit :
> > On Monday 11 November 2019 ajh-valmer wrote:
> > > > > J'ai migré de Stretch vers Buster.
> > > > > Carte graphique Nvidia geforce proprio, qui marchait
> > > > > parfaitement sous Stretch.
> > > > > linux-headers-4.19... et linux-image-4.19.


> > > Pour l'installation des drivers sous stretch
> > >


> > J'ai trouvé ce site :>

>
>r-linux


> apt-cache policy nvidia-detect
> C'est dans les dépôts non-free


La carte est bien détectée.
Quelque soit le pilote choisi, pilote Free ou Non-Free.
pas de bureau graphique (Trinity-TDE).
Ni lightdm, ni tdm-trinity (gestionnaire de connexion) ne s'affichent.
S'agit-il de TDE qui ne s'accomode pas de Buster ?

Dernière nouvelle, en lançant X en mode console,
le bureau s'est lancé mais avec une résolution beaucoup trop faible,
et impossible de l'augmenter.

Y a bien sur la ML un inscrit qui est sous Buster et TDE ? :-)

Bonne nuit.
ajh-valmer (14/11/2019, 12h40)
On Tuesday 12 November 2019 19:45:49 lann wrote:
> apt-cache policy nvidia-detect
> nvidia-detect:
> Installé : 418.74-1
> Candidat : 418.74-1
> Table de version :
> *** 418.74-1 990
> 990 stable/non-free amd64
> Packages 100 /var/lib/dpkg/status
> C'est dans les dépôts non-free


Merci,
mais c'est un paquet 64 bits,
et ma buster est en 32 bits.
Elle n'apparait pas via "apt-cache search nvidia-detect"
malgré que mon sources.list est bien configuré avec "non free".
À moins qu'elle fonctionnera quand même ?

Bonne journée,

A. Valmer
Daniel Caillibaud (14/11/2019, 13h10)
Le 14/11/19 à 11h38, "ajh-valmer" <ajh.valmer> a écrit :
> mais c'est un paquet 64 bits,
> et ma buster est en 32 bits.
> Elle n'apparait pas via "apt-cache search nvidia-detect"
> malgré que mon sources.list est bien configuré avec "non free".
> À moins qu'elle fonctionnera quand même ?


Non, n'existe que pour
amd64, donc tu ne peux pas l'installer sur ta buster i386 (32 bits).

Ce paquet sert à détecter quels paquets nvidia sont le plus adaptés à ta
carte vidéo.

Mais tu peux installer manuellement ces paquets, reste à trouver parmi

les paquets à installer pour ta carte vidéo.

Regarde si ta carte est listée sur

ou


Installer l'un des deux pourrait régler ton pb?

Peut-être que nvidia-legacy-340xx-driver ou nvidia-legacy-390xx-driver
suffirait, je laisse d'autres le confirmer.
ajh-valmer (14/11/2019, 19h10)
On Thursday 14 November 2019 12:08:51 Daniel Caillibaud wrote:
> Regarde si ta carte est listée...
> Peut-être que nvidia-legacy-340xx-driver ou nvidia-legacy-390xx-driver
> suffirait, je laisse d'autres le confirmer.


Merci à tous ceux qui m'ont aidé.

J'ai purgé complètement (reset) l'installation des xserver-xorg, nvidia
et par "nvidia-uninstall".

J'ai choisi le driver nvidia free (nvidia-legacy-340xx-driver).
Au reboot, victoire ! It works.

Des configurations ont été perdues avec Buster.
long temps pour les remettre.

Sauf erreur, je pense que le driver non-free de nvidia
n'est plus supporté par buster ou son noyau 4.19.
Ce driver fonctionnait mais avec une résolution faible,
sans pouvoir l'augmenter.

Bonne soirée,

A. Valmer
didier.gaumet (15/11/2019, 12h00)
Le jeudi 14 novembre 2019 18:10:03 UTC+1, ajh-valmer a écrit :
[...]
> J'ai choisi le driver nvidia free (nvidia-legacy-340xx-driver). [...]


Le pilote libre c'est Nouveau, le pilote que tu indiques est la version ancienne (legacy) du pilote propriétaire Nvidia
Eric Degenetais (15/11/2019, 12h20)
Bonjour
Le jeu. 14 nov. 2019 à 18:04, ajh-valmer <ajh.valmer> a écrit :

> On Thursday 14 November 2019 12:08:51 Daniel Caillibaud wrote:
> Merci à tous ceux qui m'ont aidé.
> J'ai purgé complètement (reset) l'installation des xserver-xorg, nvidia
> et par "nvidia-uninstall".
> J'ai choisi le driver nvidia free (nvidia-legacy-340xx-driver).
> Au reboot, victoire ! It works.
> Des configurations ont été perdues avec Buster.
> long temps pour les remettre.
> Sauf erreur, je pense que le driver non-free de nvidia
> n'est plus supporté par buster ou son noyau 4.19.

Plus probablement, il ne convient pas (dans cette version) à votre
matériel.

> Ce driver fonctionnait mais avec une résolution faible,

Ce qui est un argument en faveur d'un driver inadapté à votre modèle de
carte graphique.

> sans pouvoir l'augmenter.
> Bonne soirée,
> A. Valmer
> Cordialement


Éric Dégenètais
Jérémy Prego (15/11/2019, 13h10)
Le 15/11/2019 à 12:00, ajh-valmer a écrit :
> On Friday 15 November 2019 10:37:11 didier.gaumet wrote:
> Je ne vois pas de pilote nvidia "nouveau",
> mais "xserver-xorg-video-nouveau".


> tout simplement parce que le pilote nouveau est intégré au noyau. il n'y a rien a installer pour l'avoir.


Jerem
[..]

Discussions similaires