gratifiant > comp.os.* > comp.os.linux.configuration

Yayel (20/12/2003, 14h09)
Salut à tous,

J'ai voulu recompiler le noyau 2.6.0 sur mon portable (meilleure prise en
charge d'acpi qu'ils disent et surtout software suspend...).

Bon, tout se passe normalement :
j'ai utilisé make oldconfig pour regénérer mon .config tout semble ok.

La compilation normale (très rapide pour les modules) mais lorsque je
démarre, j'ai un kernel panic :

VFS: Cannot open root device "LABEL=/" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)

Pourtant Grub a l'air bien configuré car dans mon fichier menu.lst, la
partion root indiqué est exactement la même que celle de mon ancien noyau
qui boot très bien dessus.

Que faire ? J'ai vu dans ce newsgroup que quelqu'un a un problème proche à
cause d'une partition reiserfs. A priori, je ne suis pas en reiserfs (fdisk
indique que mon type de partition est 83). Comme ce n'est pas moi qui ai
installé la distrib, j'ai un doute. Comment savoir si on est en ext2, ext3
ou reiser fs ?

Merci d'avance car là, je coince.

Yayel
gerard patel (20/12/2003, 14h36)
On Sat, 20 Dec 2003 13:09:02 +0100, Yayel
<yayel2> wrote:

>Que faire ? J'ai vu dans ce newsgroup que quelqu'un a un problème proche à
>cause d'une partition reiserfs. A priori, je ne suis pas en reiserfs (fdisk
>indique que mon type de partition est 83).


une partition ReiserFS peut très bien avoir comme type 83

> Comme ce n'est pas moi qui ai
>installé la distrib, j'ai un doute. Comment savoir si on est en ext2, ext3
>ou reiser fs ?


avec df

Gérard Patel
J. Mayer (20/12/2003, 15h15)
On Sat, 20 Dec 2003 13:09:02 +0100, Yayel wrote:

> Salut à tous,
> J'ai voulu recompiler le noyau 2.6.0 sur mon portable (meilleure prise en
> charge d'acpi qu'ils disent et surtout software suspend...).
> Bon, tout se passe normalement :
> j'ai utilisé make oldconfig pour regénérer mon .config tout semble ok.
> La compilation normale (très rapide pour les modules) mais lorsque je
> démarre, j'ai un kernel panic :
> VFS: Cannot open root device "LABEL=/" or unknown-block(0,0)
> Please append a correct "root=" boot option
> Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)


Il faut à priori indiquer root=MM:mm
ou MM est le major du bloc-device
et mm le minor.
Pour /dev/hda1: MM=03 mm=01

> Pourtant Grub a l'air bien configuré car dans mon fichier menu.lst, la
> partion root indiqué est exactement la même que celle de mon ancien noyau
> qui boot très bien dessus.
> Que faire ? J'ai vu dans ce newsgroup que quelqu'un a un problème proche à
> cause d'une partition reiserfs. A priori, je ne suis pas en reiserfs (fdisk
> indique que mon type de partition est 83). Comme ce n'est pas moi qui ai
> installé la distrib, j'ai un doute. Comment savoir si on est en ext2, ext3
> ou reiser fs ?


Le type de partition importe peu. C'est surtout pour Windows qu'il est
là. Les vrais OS se basent sur le contenu des partitions pour savoir
ce que c'est. De même qu'ils se basent sur le contenu des fichiers
plutôt que sur d'hypothétiques extension pour les identifier.
Pour les partitions, les seules exceptions sont les types de partition
étendues.

Pour connaitre le type d'un file-system monté:
cat /proc/mounts
Yayel (20/12/2003, 15h32)
gerard patel wrote:

> avec df


Ok avec un df -T, je vois que ma partition est en ext3. Mais alors je ne
vois pas pourquoi le nouveau noyau ne veut pas monter root.

Yayel
Yayel (20/12/2003, 20h53)
J. Mayer wrote:

> Il faut à priori indiquer root=MM:mm
> ou MM est le major du bloc-device
> et mm le minor.
> Pour /dev/hda1: MM=03 mm=01


Effectivement, ça marche !

Mais il fallait le savoir, ça : /dev/hda5 = 0305

En plus, ce qui est étonnant, c'est que le make install fait la même erreur
que moi dans le menu.lst de grub.

En tout cas grand merci !

Yayel
J. Mayer (21/12/2003, 15h22)
On Sat, 20 Dec 2003 19:53:01 +0100, Yayel wrote:

> J. Mayer wrote:
> Effectivement, ça marche !
> Mais il fallait le savoir, ça : /dev/hda5 = 0305
> En plus, ce qui est étonnant, c'est que le make install fait la même erreur
> que moi dans le menu.lst de grub.


Oui, il faut le savoir... J'ai découvert celà en lisant la mailing
list du kernel, mais il parait que c'était éjà la méthode "officielle"
avec le 2.4. Et ça devient la seule méthode disponible pour le 2.6.
Si j'ai bien compris, le problème est le suivant:
au moment du boot, le kernel n'a pas encore de "namespace" correct
et ne peut donc pas trouver /dev/xxx . Le 2.4 construisait en
mémoire un chemin pour trouver le device, alors que le 2.6 identifie
le device par son major/minor, qui sont déjà disponibles, ce qui
fait que l'arborescence /dev n'a pas besoin d'être construite en
RAM de façon temporaire avant le boot.
Mon explication doit être incomplête, je n'ai pas regardé tout ce
code de près, mais je crois que c'est "l'esprit" du problème...
Si quelqu'un a une explication plus précise...
Vincent (22/12/2003, 00h23)
J. Mayer wrote:
[..]
> Mon explication doit être incomplête, je n'ai pas regardé tout ce
> code de près, mais je crois que c'est "l'esprit" du problème...
> Si quelqu'un a une explication plus précise...


Je suis la personne qui a posté le message précédemment pour cette
erreur; on m'avait conseillé de ne pas utiliser l'ancienne version de
reiserfs qui n'était pas compatible du tout avec celle prise en charge
par le 2.6... j'ai donc modifié mon sdf et suis maintenant en ext3.
Malheureusement, j'avais tjs la mm erreur, et je pensais que ce post
arrivait au bon moment pour résoudre mon pb; il n'en est malheureusement
rien ! au démarrage de ma machine (utilisation de lilo), je sélectionne
la bonne img à booter, et ajoute l'option root=0303 (j'ai essayé tout
type de combinaisons : 303, 03:03, et autres); pas de pot, je tombe sur:

VFS : cannot append root device "303" or hda3 (-> bonne partition pourtant!)
[...]
[...]

y a-t-il quelque chose que j'aurais oublié ?
merci par avance pour vos réponses...
Vincent (22/12/2003, 01h16)
> Je suis la personne qui a posté le message précédemment pour cette
[..]
> pourtant!)
> [...]
> [...]


pb résolu à coup de google en enlevant l'option de config du kernel
CONFIG_PARTITION_ADVANCED (??);
bref j'ai pu furtivement tester le 2.6; je reste un peu déçu sur
quelques points :
- carte son supportée avec la version d'alsa que m'avait installé la
slack 9.1 et qu'il m'est pour l'instant impossible de faire fonctionner
- freeze au démarrage lorsque je boote sur une kernel en ayant inclu la
gestion de l'acpi
- touchpad horrible à manier (précision, etc.) avec les options par
défaut (pas encore cherché comment changer tout ça...).

mais bon, ça fait que 10 minutes que je suis dessus, alors j'imagine que
les solutions - ou du moins certaines - vont apparaitre avec un peu de
recherche...
@+
Vincent.
J. Mayer (22/12/2003, 03h52)
On Mon, 22 Dec 2003 00:16:10 +0100, Vincent wrote:

> pb résolu à coup de google en enlevant l'option de config du kernel
> CONFIG_PARTITION_ADVANCED (??);


Si tu selectionnes celà, il faut aussi sélectionner les schémas
de partitionnement que tu veux utiliser, car par défaut, le kernel
n'en reconnait aucun. Généralement, il faut au moins:
PC BIOS (MSDOS partition tables) support

Quand à moi, j'utilise aussi:
BSD disklabel (FreeBSD partition tables) support
Windows Logical Disk Manager (Dynamic Disk) support
Macintosh partition map support

Pour pouvoir échanger facilement des disques avec d'autres machines.

> bref j'ai pu furtivement tester le 2.6; je reste un peu déçu sur
> quelques points :
> - carte son supportée avec la version d'alsa que m'avait installé la
> slack 9.1 et qu'il m'est pour l'instant impossible de faire fonctionner


Là, je ne sais pas, j'utilise toujours OSS, l'ALSA du 2.6 ayant montré
des signes de faiblesses sur mes machines avec les versions de test.

> - freeze au démarrage lorsque je boote sur une kernel en ayant inclu la
> gestion de l'acpi


l'ACPI est notoirement instable...

> - touchpad horrible à manier (précision, etc.) avec les options par
> défaut (pas encore cherché comment changer tout ça...).


A mon humble avis, un touchpad est tout le temps horrible.
Enfin, pour le mien (sur un Ibook), quel que soit l'OS, j'ai du mal...

> mais bon, ça fait que 10 minutes que je suis dessus, alors j'imagine que
> les solutions - ou du moins certaines - vont apparaitre avec un peu de
> recherche...


Courage...
Discussions similaires