gratifiant > linux.debian.user.french

Michel (11/01/2020, 18h30)
Bonjour,

Sous Debian Stretch, je viens de changer mon imprimante. J'ai eu
plusieurs HP deskjet multifonctions imprimante + scanner, mais vu le
prix des cartouches et l'utilité pour moi de la couleur, j'ai donc
décidé d'acheter une laser N/B.
Tout fonctionne SAUF le scanner. J'ai mis à jour les pilotes, et même
upgradé en backports, mais rien à faire, le scan démarre, puis s'arrête
avec une erreur, quelque soit l'application ( xsane, scanimage, hp-scan,
etc... )
En lançant hp-scan, j'ai le message suivant:
error: SANE: Error during device I/O (code=9)
À priori, en cherchant sur internet, ce problème est récurant. HP
abandonnerait-il les logiciels libres?

Quelqu'un a-t-il rencontré ce type de problème? Ou mieux, trouvé une
solution?

Merci
Michel
Gaëtan Perrier (11/01/2020, 20h30)
Le samedi 11 janvier 2020 à 17:09 +0100, Michel a écrit :
[..]
> solution?
> Merci
> Michel


Selon cette page

le support est complet depuis la version 3.18.4. Dans stretch la version de
base est la 3.16.11 et en backports 3.18.12. Tu confirmes avoir cette dernière
?
Sinon j'ai souvenir avoir eu des problèmes avec une version backports de hplip
que j'avais résolu en installant hplip depuis


A+
Michel (11/01/2020, 22h10)
Le 11/01/2020 à 19:30, Gaëtan Perrier a écrit :
[..]
>
> A+
> Gaëtan

En effet, je confirme que le hplip utilisé est en version 3.18.12 des
backports.
J'ai aussi essayé l'autre possibilité ( 3.19.12 actuellement ) mais
l'installation échoue sur un problème de dépendance. Sur le net, dans
des forums anglophones, des personnes ont installés ces nouvelles
versions avec le même résultat ( le scan démarre puis échoue, comme s'il
y avait un problème de timeout ).

Merci de ta réponse
Michel
k6dedijon (12/01/2020, 05h10)
Bonjour Michel,
J'ai eu aussi quelques difficultés à reconnaître le scanner de mon imprimante multi-fonction lors de sa mise n route il y a environ 3 ans.
Mais sur internet, j'ai trouvé la manière de la faire reconnaître par x-sane et je n'ai plus de soucis.
Le problème qui gène le raisonnement vient du fait que le gestionnaire de l'impression est lié au constructeur et que le scanner est générique.
Voilà mon retour d'expérience.
N'étant pas informaticien, je ne saurais en dire plus.
Cassis

----- Mail d'origine -----
De: Michel <cft1>
À: debian-user-french
Envoyé: Sat, 11 Jan 2020 20:47:13 +0100 (CET)
Objet: Re: HP laserjet pro M28a

Le 11/01/2020 à 19:30, Gaëtan Perrier a écrit :
[..]
>
> A+
> Gaëtan

En effet, je confirme que le hplip utilisé est en version 3.18.12 des
backports.
J'ai aussi essayé l'autre possibilité ( 3.19.12 actuellement ) mais
l'installation échoue sur un problème de dépendance. Sur le net, dans
des forums anglophones, des personnes ont installés ces nouvelles
versions avec le même résultat ( le scan démarre puis échoue, comme s'il
y avait un problème de timeout ).

Merci de ta réponse
Michel
Michel (12/01/2020, 10h30)
Le 12/01/2020 à 04:10, k6dedijon a écrit :
> Bonjour Michel,
> J'ai eu aussi quelques difficultés à reconnaître le scanner de mon imprimante multi-fonction lors de sa mise n route il y a environ 3 ans.
> Mais sur internet, j'ai trouvé la manière de la faire reconnaître par x-sane et je n'ai plus de soucis.
> Le problème qui gène le raisonnement vient du fait que le gestionnaire de l'impression est lié au constructeur et que le scanner est générique.
> Voilà mon retour d'expérience.
> N'étant pas informaticien, je ne saurais en dire plus.
> Cassis


Bonjour,

En fait, il est reconnu, car lorsque l'on lance un scan, la "tête" fait
son aller / retour puis là il y a cette erreur:
error: SANE: Error during device I/O (code=9)
et le fichier généré est vide.

Je viens de refaire un test depuis une sid à jour ( depuis mon portable
) et idem; pourtant, les pilotes HPLIP sont les plus récents.
Jérémy Prego (12/01/2020, 10h50)
Bonjour,

avez vous essayé d'installer hplip-plugins ?


ici, ça a résolu ce souci que j'avais depuis un certain temps avec ma
laserjet.

il faut télécharger la  même version du plugin que votre version de
hplip, et lancer le .run.

Jerem
Le 11/01/2020 à 20:47, Michel a écrit :
[..]
Michel (12/01/2020, 11h50)
Le 12/01/2020 à 09:50, Jérémy Prego a écrit :
> Bonjour,
> avez vous essayé d'installer hplip-plugins ?
>
> ici, ça a résolu ce souci que j'avais depuis un certain temps avec ma
> laserjet.
> il faut télécharger la  même version du plugin que votre version de
> hplip, et lancer le .run.


Oui, ça a été fait avec les diverses versions de hplip.

Tant pis, je pense que ce sera mon dernier achat chez HP, je suis
d'autant plus déçu que j'avais parcouru leur site, et il y est indiqué
en clair que cette machine est totalement supportée, tant l'imprimante
que le scanner!
didier.gaumet (12/01/2020, 11h50)
Le samedi 11 janvier 2020 19:30:02 UTC+1, Gaëtan Perrier a écrit :

> Selon cette page
>
> le support est complet depuis la version 3.18.4. [...]


pour préciser le propos de Gaëtan, le tableau indique que:
- ce modèle n'a pas besoin des plug-ins
- les support est complet mais uniquement sur le domaine défini: contrairement à une majorité d'autres imprimantes/combos du tableau, la connectivité de ce modèle est USB, pas USB/réseau.
Michel (12/01/2020, 12h20)
Le 12/01/2020 à 10:50, didier.gaumet a écrit :
> Le samedi 11 janvier 2020 19:30:02 UTC+1, Gaëtan Perrier a écrit :
> [...]
> pour préciser le propos de Gaëtan, le tableau indique que:
> - ce modèle n'a pas besoin des plug-ins


Dès le premier scan, les plug-ins sont réclamés par le système ( malgré
ce qui est indiqué dans la doc de HP ).

> - les support est complet mais uniquement sur le domaine défini: contrairement à une majorité d'autres imprimantes/combos du tableau, la connectivité de ce modèle est USB, pas USB/réseau.


Bien sûr, il n'y a que l'USB sur ce modèle.

Merci.
Michel
didier.gaumet (12/01/2020, 21h40)
Le dimanche 12 janvier 2020 11:20:03 UTC+1, Michel a écrit :
[...]
> Bien sûr, il n'y a que l'USB sur ce modèle.


Ah ben tu vois, ma contribution était super utile ;-)
désolé, y a des jours où ce que je dis ne passe que trop brièvement par mon cerveau ;-)

Plus sérieusement, au hasard, pour voir, tu as essayé de tester un scan en root (ou sudo) pour voir si éventuellement ça marche?
Michel (13/01/2020, 10h00)
Le 12/01/2020 à 20:40, didier.gaumet a écrit :
> Le dimanche 12 janvier 2020 11:20:03 UTC+1, Michel a écrit :
> [...]
>> Bien sûr, il n'y a que l'USB sur ce modèle.

> Ah ben tu vois, ma contribution était super utile ;-)
> désolé, y a des jours où ce que je dis ne passe que trop brièvement par mon cerveau ;-)
> Plus sérieusement, au hasard, pour voir, tu as essayé de tester un scan en root (ou sudo) pour voir si éventuellement ça marche?

Oui, mais c'est le même résultat, ce n'est pas un problème de droit.
Jerome Flesch (13/01/2020, 11h50)
Le 2020-01-12 09:05, Michel a écrit :
> Bonjour,
> En fait, il est reconnu, car lorsque l'on lance un scan, la "tête" fait
> son aller / retour puis là il y a cette erreur:
> error: SANE: Error during device I/O (code=9)
> et le fichier généré est vide.
> Je viens de refaire un test depuis une sid à jour ( depuis mon portable
> ) et idem; pourtant, les pilotes HPLIP sont les plus récents.


Bonjour,

Je développe une librairie de scan cross-platform appelée Libinsane[1].
Pendant le développement du support de Sane, j'ai remarqué que certains
backends Sane (Epson[2], HP[3], ...), renvoient parfois une erreur I/O
au lieu d'indiquer la fin du flux de papiers. Dans ton cas, tu n'as
qu'un scanner à plat donc ce ne devrait pas poser problème, mais c'est
peut-être un indice: Une théorie pourrait être qu'il ne détecte pas de
papier dans le scanner.

Dans tout les cas, je serais intéressé si tu pouvais m'aider en
complétant ma base de données de scanners[4]. Est-ce que tu accepterais
de m'envoyer un rapport de test de scan avec l'outil IronScanner ?
IronScanner est disponible ici:
. Comme tu es sous
Stretch, le binaire pré-compilé ne fonctionnera probablement pas. Il te
faudra suivre les instructions pour l'installer à partir des sources.
Avec ce rapport, qui sait, je pourrais peut-être te fournir des indices
pour trouver la cause exacte de ton problème.
didier.gaumet (13/01/2020, 12h00)
Lorsque tu as lancé la commande hp-scan as-tu augmenté la verbosité des messages d'erreur? ça te donnerait peut-être plus d'indices sur la raison du dysfonctionnement (option --logging=debug ou -g).Peut-être aussi regarder du côté de hp-logcapture pour éplucher les logs plus commodément.
Michel (13/01/2020, 12h20)
Le 13/01/2020 à 10:50, Jerome Flesch a écrit :
[..]
>
> [3]
> [4]


Pas de problème. Dès que j'ai un moment je fais les tests cette semaine.

Michel
Michel (13/01/2020, 12h50)
Le 13/01/2020 à 11:00, didier.gaumet a écrit :
> Lorsque tu as lancé la commande hp-scan as-tu augmenté la verbosité des messages d'erreur? ça te donnerait peut-être plus d'indices sur la raison du dysfonctionnement (option --logging=debug ou -g). Peut-être aussi regarder du côté de hp-logcapture pour éplucher les logs plus commodément. Oui, hp-scan -g, voici la sortie:


michel@Ariane:~$ hp-scan -g

HP Linux Imaging and Printing System (ver. 3.18.12)
Scan Utility ver. 2.2

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

hp-scan[9218]: debug: getDeviceUri(None, None, ['hpaio'], {'scan-type':
(<built-in function gt>, 0)}, , True)
hp-scan[9218]: debug: Mode=0
warning: No destinations specified. Adding 'file' destination by default.
Using device hpaio:/usb/HP_LaserJet_MFP_M28-M31?serial=VNC5L02598
Opening connection to device...
hp-scan[9218]: debug: Supported source Options: ['Flatbed'] size=1
hp-scan[9218]: debug: Device supported resolutions [200, 300, 600]

Resolution: 300dpi
Mode: gray
Compression: JPEG
Scan area (mm):
Top left (x,y): (0.000000mm, 0.000000mm)
Bottom right (x,y): (215.900009mm, 297.010681mm)
Width: 215.900009mm
Height: 297.010681mm
Destination(s): file
Output file:
hp-scan[9218]: debug: Supported modes: ['gray', 'color'] size=2
warning: File destination enabled with no output file specified.
Setting output format to PNG for greyscale mode.
warning: Defaulting to '/home/michel/hpscan001.png'.

Warming up...

Scanning...
error: SANE: Error during device I/O (code=9)
Closing device.
michel@Ariane:~$

Ceci semble fréquent en regardant sur internet, avec plusieurs
multifonction HP.
Discussions similaires