gratifiant > comp.divers.* > comp.infosystemes.www.navigateurs

Une Bévue (15/11/2006, 15h31)
j'ai une page contenant à sa gauche une image svg et à sa droite "la
même" rasterisée en png.

<http://www.yvon-thoraval.com/SVG/inline/leafnode.xml>

je l'ai testée sur différents navigateurs :

WebKit latest nightly - ok svg + ok png
MineField 3.0a1 - ok svg + ok png
Safari 2 - ok png
Camino latest - ok svg + ok png
Flock - ok svg + ok png
iCab - ok png
Mozilla - ok png
Omniweb - ok svg + ok png
Opera - ok svg + ok png
SeaMonkey - ok svg + ok png
Shiira 1.2.2 - que dalle prend ma page pour du rss ?
Shiira 2.0b1 - que dalle prend ma page pour du rss ?
Firefox 2 (fr) - ok svg + ok png

voil,a sur Mac OS 10.4 latest.

ça donne quoi sur win* et nix ???

question validation ca ne passe pas en xhtml strict le validateur
n'admet pas :

1 - Error Line 4 column 13: there is no attribute "xmlns:svg".
2 - Error Line 5 column 18: there is no attribute "xmlns:xlink".
et donc tout ce qui est en svg:xyz

les lignes essentielles étant :
<?xml version="1.0"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
xmlns:svg="http://www.w3.org/2000/svg"
xmlns:xlink="http://www.w3.org/1999/xlink"
xml:lang="fr"
lang="fr">

pourtant le validateur reconnait que :

Root Namespace:
Other Namespaces

*
*

donc je ne pige pas comment il faudrait faire pour le contenter...
MELMOTH (15/11/2006, 17h52)
Ce cher mammifère du nom de Une Bévue nous susurrait, le mercredi
15/11/2006, dans nos oreilles grandes ouvertes mais un peu sales quand
même, et dans le message
<1houkk1.jdh8au39wwi3N%yt.trash>, les doux mélismes
suivants :

> ça donne quoi sur win* et nix ???


Win :

IE/Clones : RSS...
Très bien sous FF et Opera...
Sergio (15/11/2006, 18h10)
Après mure réflexion, Une Bévue a écrit :
[..]
> Firefox 2 (fr) - ok svg + ok png
> voil,a sur Mac OS 10.4 latest.
> ça donne quoi sur win* et nix ???


FF 2.0 sous Windows XP : ça marche presque : les feuilles sont décalées
de 180° (idem Opera 9.02).
rm (15/11/2006, 18h34)
Salut,

Le mercredi 15 novembre 2006 à 14:31, Une Bévue a écrit :

> <http://www.yvon-thoraval.com/SVG/inline/leafnode.xml>
> je l'ai testée sur différents navigateurs : [...]
> ça donne quoi sur win* et nix ???


sous Win XP SP2:

IE7.0.5730.11 (et clones) affiche le source colorisé du document XML, c'est
déjà pas mal :)

SVG+PNG affichés correctement dans Firefox 2.0 et 3.0a1, SeaMonkey 1.0.6,
Opera 9.10-8649 et OrcaBrowser 1.0RC3

OffByOne v3.5d n'affiche rien, c'est pas un scoop.

Swift 0.1 (webkit) n'affiche que le PNG.

@+
Vince35 (15/11/2006, 18h40)
Une Bévue a écrit :
[..]
> *
> *
> donc je ne pige pas comment il faudrait faire pour le contenter...


il suffit de suivre les explications...a chaque erreur qu'il te trouve
(si t'es bilingue)
rm (15/11/2006, 18h48)
Pour compléter: bizarrement, Opera 8.5-7700 affiche mal le SVG et pas du
tout le PNG, alors qu'Opera 7.54-3865a et 6.02-1101 affichent tous les deux
très bien le PNG et pas du tout le SVG...
Opera 5.11-904b et 4.02.0.462 et 3.62.0.326 n'affichent rien, mais rien du
tout :)

@+
Yamo' (15/11/2006, 20h25)
Salut,
Le Wed, 15 Nov 2006 14:31:46 +0100, Une Bévue a écrit
ce message ( <1houkk1.jdh8au39wwi3N%yt.trash> ):

> j'ai une page contenant à sa gauche une image svg et à sa droite "la
> même" rasterisée en png.
> <http://www.yvon-thoraval.com/SVG/inline/leafnode.xml>


Voici 5 copies d'écran :

Fait sur Ubuntu Dapper Drake (Linux), à noter que seuls Firefox et Epiphany
viennent des dépots d'Ubuntu.
Yamo' (15/11/2006, 20h27)
Le Wed, 15 Nov 2006 17:34:58 +0100, rm a écrit ce message (
<1l82w0isr9sn.dlg> ):

> IE7.0.5730.11 (et clones) affiche le source colorisé du document XML, c'est
> déjà pas mal


IE6 avait besoin d'un plug-in pour le SVG et j'ai lu que IE7 n'aura pas
droit à son plugin :(
Une Bévue (15/11/2006, 20h38)
Sergio <laposte> wrote:

> FF 2.0 sous Windows XP : ça marche presque : les feuilles sont décalées
> de 180° (idem Opera 9.02).


le décalage des feuilles est "normal", j'ai rasterisé à 180° ;-)

passeke les feuilles peuvent tourner :
<http://yvon-thoraval.com/SVG/leafnode.svg>
un cadenas qui bouge :
<
lock_opening.html>
Une Bévue (15/11/2006, 20h38)
rm <ramon> wrote:

> Pour compléter: bizarrement, Opera 8.5-7700 affiche mal le SVG et pas du
> tout le PNG, alors qu'Opera 7.54-3865a et 6.02-1101 affichent tous les deux
> très bien le PNG et pas du tout le SVG...


j'ai un peu le même pb avec webkit (safari nightly) il a du mal à
afficher le png il faut cliquer à l'endroit où il doit être titiller un
peu et il appara^t...

pour le svg pas de pb...

je trouve que le svg en xml est relativement encourageant...
Une Bévue (15/11/2006, 20h38)
Vince35 <v.b> wrote:

> . yvon-thoraval.com%2FSVG%2Finline%2Fleafnode.xml
> il suffit de suivre les explications...a chaque erreur qu'il te trouve


ouais je lis et comprends le patois mai sla c'est du chinois )))

euh si je n'ajoute pas ces namesapces ça ne peut pas marcher (j'ai pompé
ça sur d'autres) je ne vois pas où les mettre ailleurs.

bon j'ai regardé aussi ce que me dit oxygen, là c'est contradictoire, il
me dit tout à la fois qu'effectivement les attributs xmlns:svg et xlink
ne sont pas valides mais aussi que les tags type svg:xyz doivent être
ajoutés à html...

j'ai posté la question sur le groupe "fr.comp.text.xml" ...

en tout cas avec xslt c'est comme ça qu'il faut faire...
Une Bévue (15/11/2006, 21h15)
Yamo' <yamo.reply-to> wrote:

> Voici 5 copies d'écran :
> Fait sur Ubuntu Dapper Drake (Linux), à noter que seuls Firefox et Epiphany
> viennent des dépots d'Ubuntu.


ok, merci beaucoup, bizarre que sur linux et seamonkey 1.5a ça ne marche
pa le svg, chez moi c'est ok avec la même "version" peut-être que les
options de compil sont différentes...
Pascal (15/11/2006, 21h21)
Le Wed, 15 Nov 2006 19:25:54 +0100, Yamo' a écrit:

> Salut,
> Le Wed, 15 Nov 2006 14:31:46 +0100, Une Bévue a écrit
> ce message ( <1houkk1.jdh8au39wwi3N%yt.trash> ):
> Voici 5 copies d'écran :


Pour compléter :
Konqueror, pas de svg, zone blanche, le png est Ok
Dillo (je me demande pq j'ai ça...) me propose de télécharger le fichier...

Pascal
Pascal (15/11/2006, 22h13)
Le Wed, 15 Nov 2006 20:15:40 +0100, Une Bévue a écrit:

> Yamo' <yamo.reply-to> wrote:
> ok, merci beaucoup, bizarre que sur linux et seamonkey 1.5a ça ne marche
> pa le svg, chez moi c'est ok avec la même "version" peut-être que les
> options de compil sont différentes...


Je l'avais oublié lui, chez moi ça marche également, mais une version plus
vieille.

SeaMonkey 1.0.6
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8)
Gecko/20061110
Fedora/1.0.6-0.6.2.fc6 pango-text SeaMonkey/1.0.6

Pascal
Yamo' (15/11/2006, 23h43)
Salut,
Pascal tapotait le 15 Nov 2006 20:13:16 GMT, ce message
<455b74db$0$11680$426a74cc> :

>Je l'avais oublié lui, chez moi ça marche également, mais une version plus
>vieille.


En effet, je n'avais pas testé avec seamonkey 1.0.5 ; j'ai du
faire une bêtise dans mon profil default celui ci ne fonctionne
plus qu'avec les version nightly build, j'attends la version 1.0.6
de frenchmozilla pour résoudre mon problème (je ne sais pas
pourquoi les releases officielles déconnent souvent avec mon
profil) :

là sur un autre profil sur seamonkey 1.0.5 (toujours linux) ça
donne ça :

Discussions similaires