gratifiant > linux.debian.user.french

Jérôme Gaulin (23/05/2005, 18h20)
Bonjour a tous,

je viens de faire l'acquisition d'un petit sony.
je n'ai pas très envie de mettre du micro$oft dessus alors j'ecris à la liste pour un peu d'aide.
si je ne m'adresse pas à la bonne liste merci de me le dire.

cat /proc/cpuinfo

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 1.73GHz
stepping : 8
cpu MHz : 1729.819
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx est tm2
bogomips : 3399.68

lspci

0000:00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML
Express Processor to DRAM Controller (rev 03)
0000:00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI
Express Root Port (rev 03)
0000:00:1b.0 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
High Definition Audio Controller (rev 04)
0000:00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) USB UHCI #1 (rev 04)
0000:00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) USB UHCI #2 (rev 04)
0000:00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) USB UHCI #3 (rev 04)
0000:00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) USB UHCI #4 (rev 04)
0000:00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) USB2 EHCI Controller (rev 04)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
0000:00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC
Interface Bridge (rev 04)
0000:00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) IDE Controller (rev 04)
0000:00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
Family) SMBus Controller (rev 04)
0000:01:00.0 VGA compatible controller: nVidia Corporation: Unknown
device 0167 (rev a1)
0000:06:03.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
0000:06:03.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000
OHCI Two-Port PHY/Link-Layer Controller
0000:06:03.3 Unknown mass storage controller: Texas Instruments
PCI7420/PCI7620 Dual Socket CardBus and Smart Card Cont. w/ 1394a-2000
OHCI Two-Port PHY/Link-Layer Cont. an
0000:06:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG
(rev 05)
0000:06:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ -
PRO/100 VE (LOM) Ethernet Controller Mobile (rev 04)

Je viens d'installer la sarge et j'ai compiler 2.6.11

J'ai quelques soucis :

1- Au niveau de la carte son , apt-get install alsa-source , compilation
pour snd-azx , les modules se load bien et alsaconf me trouve bien ma
carte mais voila :

lsmod

Module Size Used by
nvidia 3922620 14
joydev 9920 0
ide_cd 42372 0
cdrom 41760 1 ide_cd
eth1394 22152 0
ohci1394 35972 0
ieee1394 112056 2 eth1394,ohci1394
i2c_i801 8844 0
i2c_core 23312 1 i2c_i801
ehci_hcd 33672 0
usbhid 27776 0
uhci_hcd 33552 0
usbcore 123256 4 ehci_hcd,usbhid,uhci_hcd
snd_azx 16608 0
snd_hda_codec 47232 1 snd_azx
snd_pcm_oss 54432 0
snd_mixer_oss 20480 1 snd_pcm_oss
snd_pcm 97160 3 snd_azx,snd_hda_codec,snd_pcm_oss
snd_timer 26884 1 snd_pcm
snd 57060 6
snd_azx,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,sn d_pcm,snd_timer
soundcore 10464 1 snd
snd_page_alloc 10244 2 snd_azx,snd_pcm
e100 37120 0
mii 5120 1 e100
ipw2200 161800 0
firmware_class 10624 1 ipw2200
ieee80211 41764 1 ipw2200
ieee80211_crypt 6472 2 ipw2200,ieee80211
rtc 13496 0

dmesg

ALSA /usr/src/modules/alsa-driver/pci/azx/hda_codec.c:416: hda_codec: no
AFG node found
ALSA /usr/src/modules/alsa-driver/pci/azx/hda_codec.c:416: hda_codec: no
AFG node found
ALSA /usr/src/modules/alsa-driver/pci/azx/azx.c:782: azx: no codecs
initialized
Intel HDA: probe of 0000:00:1b.0 failed with error -6

alsamixer

alsamixer: function snd_ctl_open failed for default: No such device
zsh: exit 1 alsamixer

2- Au niveau de la carte wifi embarquée . avec les modules ipw22OO :

dmesg

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.3
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI Interrupt Link [LNKG] enabled at IRQ 10
ACPI: PCI interrupt 0000:06:04.0[A] -> GSI 10 (level, low) -> IRQ 10
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw-2.2-boot.fw load failed: Reason -2
ipw2200: Unable to load firmware: 0xFFFFFFFE
ipw2200: failed to register network device
ipw2200: probe of 0000:06:04.0 failed with error -5

et du cote de pcmcia :
/etc/init.d/pcmcia start
Starting PCMCIA services: Error: Failed to load pcmcia_core
zsh: exit 1 /etc/init.d/pcmcia start

....argh

3- J'ai installer le bootsplash et le fb, qui fonctionne de manière
étrange :

Le framebuffer fonctionne sur toute les tty sauf le premier !
le bootsplash fonctionne seulement pour la phase d'arret du pc ( barre
de progression.. impec quoi), et pas pour la phase de boot au je n'ai
que du texte.
De plus l'écran est en 16:10, en 1280x800, est ce possible d'avoir le
bootsplash et fb dans ce format et non en 1024x768?

Je vous mettrais bien mes /init.d/rc et autre mais ca risque de faire un
peu long le post ! demander les moi.;)

Voila si certains parmis vous ont ce portable, ou si vous voyez des
issues à mes soucis techniques je vous en serais grandement
reconnaissant, je n'ai pas envie de me rabbatre sur un windows... merci !

Cordialement.
Jérôme Gaulin (25/05/2005, 11h40)
Jérôme Gaulin a écrit :

[..]
>issues à mes soucis techniques je vous en serais grandement
>reconnaissant, je n'ai pas envie de me rabbatre sur un windows... merci !
>Cordialement.

Je me repond tout seul :)
1 - Alsa -> prendre les derniers drivers snd-hda-intel (ooo c'est
original ca ;) )
2 - Carte wifi -> Fonctionne tres bien. Attention cepdendant à la forme
des noms des fichiers firmwares que vous telechargez. Le module attend
une syntaxe particulière. j'ai chercher longtemps avt de m'en rendre compte.
-PCMCIA doesnt work sur cette machine avec les noyaux 2.6.
3 - X fonctionne bien en 1280:800 (format 16/10eme, j'aime beaucoup )
par contre vu que ce n'etait pas dans les normes, le bootplash ne
fonctionne qu'en 1024x768. dommage !

pour finir, je noterai ce portable 16/20 ,
+ ergonomie
+disque 100go
+ graveur CD/DVD double couche et autre.
+poid
+ silence de fonctionnement
- Autonomie ( vendu avec une mauvaise batterie pour pousser a l'achat de
la high longevity sur sony.com :/ )
- pcmcia qui ne marche pas (encore.. ^^ j'espere)

Voila, Bien à vous.
Jérôme gaulin.
Discussions similaires