gratifiant > microsoft.* > microsoft.excel

Billymax (28/07/2006, 15h26)
Peut-on éviter "#NOMBRE!" ds la cellule lorque le calcul de
différence de date n'est pas réalisable (car date 1 < à date 2) ?
MonOnc' (28/07/2006, 15h31)
bonjour,

=SI(ESTERREUR(DATEDIF(date1;date2;"dd"));"";DATEDI F(date1;date2;"dd"))

Le 28/07/2006, Billymax a supposé :
Nicolas B. (28/07/2006, 15h34)
Bonjour ???
....
Merci ???

=si(esterreur(TaFormule);"";TaFormule)

Nicolas B.

Billymax a écrit :
FxM (28/07/2006, 15h45)
Billymax a écrit :
> Peut-on éviter "#NOMBRE!" ds la cellule lorque le calcul de
> différence de date n'est pas réalisable (car date 1 < à date 2) ?


Billymax,

et si tu restais dans le même fil ? Pour cela, utilise un lecteur de
news plutôt que de passer par le site web.
Clique sur le lien et accepte l'abonnement (c'est gratuit)


Sinon, vois du coté de max(date1;date2) et min(date1;date2) sous la
réserve que les deux dates soient saisies ...

@+
FxM
Billymax (28/07/2006, 15h56)
J'ai essayé d'incorporer votre formule ds la mienne qui est :
=SI(DATEDIF(C2;"07/05/05";"y")>1;DATEDIF(C2;"07/05/05";"y")&SI(DATEDIF(C2;"07/05/05";"y")>1;"
ans";" an");DATEDIF(C2;"07/05/05";"m")&" mois")

C'est une formule pour calculer une différence de dates en jouant avec
les expressions "an", "ans" et "mois".

Ms sans succès...
Sauriez-vs m'aider ?
Merci

MonOnc' a écrit :
[..]
Nicolas B. (28/07/2006, 16h41)
Salut,

Tu peux essayer ceci :
=si(c2<38479;DATEDIF(C2;"07/05/05";"y")&SI(DATEDIF(C2;"07/05/05";"y")>1;"ans";"
an");DATEDIF(C2;"07/05/05";"m")&" mois");"")

A+
Nicolas B.

Billymax a écrit :
[..]
Billymax (28/07/2006, 17h04)
Merci :)
Ms ça ne marche pas (la formule contient une erreur)...

Nicolas B. a écrit :
[..]
Billymax (28/07/2006, 17h08)
test
Nicolas B. (28/07/2006, 17h13)
Excuse-moi, je n'avais pas testé la formule :-(

=SI(C2<38479;SI(DATEDIF(C2;"07/05/05";"y")>1;DATEDIF(C2;"07/05/05";"y")&SI(DATEDIF(C2;"07/05/05";"y")>1;"
ans";" an");DATEDIF(C2;"07/05/05";"m")&" mois");"")

A+
Nicolas B.

Billymax a écrit :
[..]
ABED HADDOU (28/07/2006, 17h54)
Re, Billymax

comment rendre la cellule vide qd calcul impossible

=SI(ESTERREUR(DATEDIF(A1;B1;"y")>0);"";SI(DATEDIF( A1;B1;"y")>0;DATEDIF(A1;B1;"y");DATEDIF(A1;B1;"m") ))

Abed_H

"Billymax" a écrit :
ChrisV (29/07/2006, 00h38)
Bonjour Billymax,

Petite variante, et quelques caractères en moins... ;-)

=SI("07/05/05">C2;SI(DATEDIF(C2;"07/05/05";"y")>1;TEXTE(DATEDIF(C2;"07/05/05";"y");"[>1]0""
ans"";[>]""1 an"";");DATEDIF(C2;"07/05/05";"m")&" mois");"")

ChrisV

"Billymax" <mc.billymax> a écrit dans le message de news:
1154095281.254968.77090...
J'ai essayé d'incorporer votre formule ds la mienne qui est :
=SI(DATEDIF(C2;"07/05/05";"y")>1;DATEDIF(C2;"07/05/05";"y")&SI(DATEDIF(C2;"07/05/05";"y")>1;"
ans";" an");DATEDIF(C2;"07/05/05";"m")&" mois")

C'est une formule pour calculer une différence de dates en jouant avec
les expressions "an", "ans" et "mois".

Ms sans succès...
Sauriez-vs m'aider ?
Merci

MonOnc' a écrit :
[..]
Billymax (01/08/2006, 14h50)
Négatif, celle-ci fait apparaitre #FORMULE! lorsque le calcul est
impossible.

ChrisV a écrit :
[..]
Discussions similaires