gratifiant > microsoft.* > microsoft.excel

Oumpahpah (21/01/2004, 22h20)
Bonsoir à tous,

Sur XL97 je disposais d'une échelle de notation de fournisseurs allant de 1à 7.
Mon échelle a changé et s'étale désormais de 0 à 10.
Quelle peut être la formule qui me permettrait de convertir les anciennes notes
en nouvelles ?
Je saisirais en A1 la note dans l'ancien barême et la formule dans A2 me
donnerait la correspondance dans le nouveau barême.

Merci d'avance pour votre aide.
Clément Marcotte (21/01/2004, 23h19)
Bonjour,

Sous réserve d'être un bon devin:

Function RéÉtale(parametre As Single) As Single

Select Case parametre

Case 1
RéÉtale = 0
Case 7
RéÉtale = 10
Case Else
RéÉtale = 10 * parametre / 7
End Select

End Function

"Oumpahpah" <oumpahpah> a écrit dans le message de
news:0264
[..]
Jean-François Aubert (22/01/2004, 00h01)
Salut Oumpahpah,

En A1 l'ancienne note à convertir
En A2 la formule
En A2:A8 liste des anciennes notes
En B2:B8 liste des nouvelles notes
Ensuite tu peux deplacer la plage A2:B8 où tu veux,
et tirer la formules sur plusieurs lignes

7 =RECHERCHEV(A1;$A$2:$B$8;2) 1 0
2 1.5
3 3
4 4.5
5 6
6 7.5
7 10
Jean-François Aubert (22/01/2004, 00h10)
Oups ! la 2ème ligne était partie se prommener !

7 =RECHERCHEV(A1;$A$2:$B$8;2)
1 0
2 1.5
3 3
4 4.5
5 6
6 7.5
7 10
Jean-François Aubert (22/01/2004, 00h42)
Re-oups, je ne fais que des erreurs,
je vais me coucher.

Oublie tout ce que j'ai dit jusqu'à maintenant.

En A1 la note à convertir

=10/6*(A1-1)
Discussions similaires