gratifiant > linux.debian.user.french

NaiosKAE{FR} (13/01/2005, 21h40)
Bonjour,

un petit soucis avec cdrecord, un cdrecord -scanbus ne me trouve pas mon
graveur alors que xcdroast grave sans soucis, du coup pour graver la
musique, pas moyen

mon graveur (/dev/hdd) est un LG 52.24.52 sur ATAPI 0,1,0 comme me
l'indique xcdroast, lorsque je passe cette option à cdrecord il ne le
trouve pas. mp3burn quant à lui plante à la normalistaion de l'audio.

Si quelqu'un à une idée, je suis preneur,

merci

Erwann
Jean-Luc Coulon (f5ibh) (13/01/2005, 21h50)
Le 13.01.2005 20:39:40, NaiosKAE{FR} a écrit :
> Bonjour,
> un petit soucis avec cdrecord, un cdrecord -scanbus ne me trouve pas
> mon graveur alors que xcdroast grave sans soucis, du coup pour graver
> la musique, pas moyen


xcdroast sait graver la musique aussi

> mon graveur (/dev/hdd) est un LG 52.24.52 sur ATAPI 0,1,0 comme me
> l'indique xcdroast, lorsque je passe cette option à cdrecord il ne le
> trouve pas. mp3burn quant à lui plante à la normalistaion de l'audio.
> Si quelqu'un à une idée, je suis preneur,


Quelle est la commande exacte que vous passez cdrecord ?

cdrecord dev=ATAPI -scanbus

(sans doute à passer en root)
NaiosKAE{FR} (13/01/2005, 23h10)
Jean-Luc Coulon (f5ibh) a écrit :

> Le 13.01.2005 20:39:40, NaiosKAE{FR} a écrit :
>> Bonjour,
>> un petit soucis avec cdrecord, un cdrecord -scanbus ne me trouve pas
>> mon graveur alors que xcdroast grave sans soucis, du coup pour
>> graver la musique, pas moyen

> xcdroast sait graver la musique aussi en passant par une image? ou alors j'ai pas trouvé.


> Quelle est la commande exacte que vous passez cdrecord ?
> cdrecord dev=ATAPI -scanbus celle la meme en sudo


il me trouve bien mon graveur au bon endroit: atapi:0,1,0
[..]
Jean-Luc Coulon (f5ibh) (13/01/2005, 23h30)
Le 13.01.2005 22:08:14, NaiosKAE{FR} a écrit :
> Jean-Luc Coulon (f5ibh) a écrit :
> en passant par une image? ou alors j'ai pas trouvé.


Création de CD, Duplication, etc ... tout dépend
Si vous avez une collection de wav, il va les graver.

> celle la meme en sudo
> il me trouve bien mon graveur au bon endroit: atapi:0,1,0


Vous dites plus haut qu'il ne le trouve pas et maintenant, vous dites
qu'il le trouve ... ??
David Dumortier (13/01/2005, 23h40)
Le Thu Jan 13 2005 à 10:08:14PM +0100, NaiosKAE{FR} dit :
> en passant par une image? ou alors j'ai pas trouvé.

[...]
oui mais la duplication de cd le permet aussi.
[...]
> >cdrecord dev=ATAPI -scanbus

> celle la meme en sudo
> il me trouve bien mon graveur au bon endroit: atapi:0,1,0


sudo cdrecord dev=ATA:0,1,0

non ?
[...]
Rolland T. Chago (14/01/2005, 00h40)
cdrecord -scanbus ne reconnait que les Lecteurs SCSI si tu as un
lecteure IDE du dois devoir utiliser l'émulateur pour convertir tes ide
la configuration commence à partir du Noyau .
voila un lien interessant

Peace

NaiosKAE{FR} wrote:
[..]
zenetics (14/01/2005, 03h10)
Bonjour,
Si topic m'interresse grandement car j'ai reussi à faire que cdrecord
detecte mon graveur emulé scsi
mais impossible de le faire graver car j'ai cdrecord (via gcomburs) qui
me dit qu'il ne trouve pas le cd viege !!!!
J'ai tenter de modifier le fstab car je me perds avec les /dev/sr0 ,
/dev/sg0 et /dev/scd0
Donc si quelqu'unpeu eclairer ma lanterne je suis preneur

thx

zenetics

Rolland T. Chago a écrit :
[..]
Jean-Michel OLTRA (14/01/2005, 08h20)
bonjour,

Le vendredi 14 janvier 2005, zenetics a écrit...

> Si topic m'interresse grandement car j'ai reussi à faire que cdrecord
> detecte mon graveur emulé scsi
> mais impossible de le faire graver car j'ai cdrecord (via gcomburs) qui
> me dit qu'il ne trouve pas le cd viege !!!!
> J'ai tenter de modifier le fstab car je me perds avec les /dev/sr0 ,
> /dev/sg0 et /dev/scd0
> Donc si quelqu'unpeu eclairer ma lanterne je suis preneur


Si tu utilises l'émulation scsi, tu fais pointer dans ta fstab le device
réel, /dev/scdX sur le point de montage (/cdrom). Mais à partir de noyau
2.6.x avex x > 8 on peut utiliser le gravage atapi, donc plus besoin
d'émulation. La commande est celle que Jean-Luc vient de donner:

cdrecord dev=ATAPI:x,y,z autres_options
NaiosKAE{FR} (14/01/2005, 09h50)
En fait il s'agissait d'un probleme de root. une fois passé les bon
parametre ca fonctionne (dev=ATAPI:0,1,0). Le soucis restant est qu'en
mode utilisateur, il refuse d'ecrire en SAO, DAO et TAO, donc reste
juste le gravage BRUT (rw96).

un autre est que mp3burn bloque à la normalisation des mp3. => mp3burn
genere des wav et x-cdroast grave les wav sur le cd. Cette solution ne
me satisfait pas à 100% mais je m'y attacherais un peu plus tard.

Erwann

merci à tous ceux qui m'ont aidé.

Jean-Michel OLTRA a écrit :
[..]
jean-luc Coulon (f5ibh) (14/01/2005, 14h20)
On Thu, Jan 13, 2005 at 11:38:02PM +0100, Rolland T. Chago wrote:
> cdrecord -scanbus ne reconnait que les Lecteurs SCSI si tu as un


cdrecord dev=<transport> -scanbus

permet de reconnaitre *tous* les lecteur
<transport> peut être ATA ou ATAPI

faire cdrecord dev=help pour obtenir la liste des transports disponibles

Jean-Luc
[..]
jean-luc Coulon (f5ibh) (14/01/2005, 14h30)
On Fri, Jan 14, 2005 at 02:08:41AM +0100, zenetics wrote:
> Bonjour,
> Si topic m'interresse grandement car j'ai reussi à faire que cdrecord
> detecte mon graveur emulé scsi
> mais impossible de le faire graver car j'ai cdrecord (via gcomburs) qui
> me dit qu'il ne trouve pas le cd viege !!!!
> J'ai tenter de modifier le fstab car je me perds avec les /dev/sr0 ,
> /dev/sg0 et /dev/scd0
> Donc si quelqu'unpeu eclairer ma lanterne je suis preneur


Le lecteur n'a pas besoin d'être dans fstab pour que la gravure fonctionne.
Il faut d'abord essayer de graver en ligne de commande avec cdrecord afin d'être
sûr que le problème ne se situe pas à ce niveau. Ensuite vous pourrezutiliser
le GUI.
Mais je crois que gcombust ne permet de n'utiliser que l'émulation SCSI. je ne
suis pas trop sûr qu'on puisse utiliser cette émulation avec 2.6 .

La gestion des graveurs avec 2.6 est difficile : ça change tout le temps.Une
version vous permet de le faire, la version suivante seulement en rrot, la
version suivante en utulisateur normal si vous utilisez le transport ATAPI et
root avec ATA, ....

Jean-Luc
[..]
NaiosKAE{FR} (14/01/2005, 14h40)
jean-luc Coulon (f5ibh) a écrit :
[..]
> version vous permet de le faire, la version suivante seulement en rrot, la
> version suivante en utulisateur normal si vous utilisez le transport ATAPI et
> root avec ATA, ....

Explication interressante qui expliquerais peut etre pourquoi je ne peux
graver qu'en root (noyau 2.6.8)

Erwann
[..]
Jean-Luc Coulon (f5ibh) (14/01/2005, 15h30)
Le 14.01.2005 13:32:16, NaiosKAE{FR} a écrit :
> jean-luc Coulon (f5ibh) a écrit :
> Explication interressante qui expliquerais peut etre pourquoi je ne
> peux graver qu'en root (noyau 2.6.8)


Avec 2.6.8.1 (de kernel.org) est arrivée une nouvelle gestion de
l'interface qui rendait celle-ci incompatible avec l'utilisation de
cdrecord sans être root.

Les noyaux 2.6.8 (il n'y a pas eu de 2.6.8.1 chez Debian) ont intégré
un backport de 2.6.9 pour corriger ce problème (qui n'était pas
vraiment un bug puisque voulu par les développerus du niyau). Mais la
gravuere des CD audio donnait des résultats illisibles.

Le passage à 2.6.9 a, semble-t-il tout, remis dans l'ordre.

Avec 2.6.10 et 2.6.11-rc1, je retrouve des problèmes de ce type : on
peut graver avec /dev/hda mais pas avec les transports ATAPI ou ATA
avec un utilisateur normal. Mais l'attaque directe /dev/hda signale
qu'on ne bénéficie pas du DMA.

Le responsable du paquet cdrecord me disait d'utiliser ATA plutôt
qu'ATAPI mais les raisons étaient plutôt obscures.

Nous sommes dépendant de cdrecord et les problèmes de relations entre
le monde libre selon Debain et l'auteur de cdrecord font que cdrecord a
un peu forké... Les intefaces graphiques reposent toutes sur cdrecord
et xcdroast refuse de graver des DVD sans cdrecord-ProDVD qui bien que
gratuit n'est pas libre... Bref...
Fabien R (14/01/2005, 20h50)
On Thursday 13 January 2005 23:38, Rolland T. Chago wrote:
> cdrecord -scanbus ne reconnait que les Lecteurs SCSI si tu as un

Je suis en kernel 2.6.9 et cdrecord reconnait mon graveur IDE.
Je me souviens que j'ai dû mettre à jour mon
fichier /etc/default/cdrecord pour k3b puisse graver (sous root uniquement
malheureusement).
-
Fabien
Nazim Baizid (14/01/2005, 21h30)
On Thu, 13 Jan 2005 20:39:40 +0100
NaiosKAE{FR} <erwann.pencreach> wrote:

> Bonjour,
> un petit soucis avec cdrecord, un cdrecord -scanbus ne me trouve pas mon
> graveur alors que xcdroast grave sans soucis, du coup pour graver la
> musique, pas moyen
> mon graveur (/dev/hdd) est un LG 52.24.52 sur ATAPI 0,1,0 comme me
> l'indique xcdroast, lorsque je passe cette option à cdrecord il ne le
> trouve pas. mp3burn quant à lui plante à la normalistaion de l'audio.
> Si quelqu'un à une idée, je suis preneur,
> merci
> Erwann


donne la sortie de lsmod
[..]

Discussions similaires