gratifiant > linux.debian.user.french

MERLIN Philippe (02/11/2019, 17h20)
Bonjour,
Depuis quelque temps suite à une mise à jour apache2 ne démarre plus sur ma debian
amd64 Sid à jour.
Voilà les diagnostics :
nov. 02 11:46:58 portable systemd[1]: Starting The Apache HTTP Server...
nov. 02 11:46:59 portable apachectl[1180]: AH00526: Syntax error on line 9 of /etc/
apache2/mods-enabled/php7.3.conf:
nov. 02 11:46:59 portable apachectl[1180]: Invalid command 'Require', perhaps misspelled
or defined by a module not inclu>
nov. 02 11:46:59 portable apachectl[1180]: Action 'start' failed.
nov. 02 11:46:59 portable apachectl[1180]: The Apache error log may have more
information.
nov. 02 11:46:59 portable systemd[1]: *apache2.service: Control process exited,
code=exited, status=1/FAILURE*

<FilesMatch ".+\.phps$">
SetHandler application/x-httpd-php-source
# Deny access to raw php sources by default # To re-enable it's recommended to
enable access to the files
# only in specific virtual host or directory
Require all denied
J'ai bien recherché sur Google mais je n'ai rien trouvé d'évident du moins pour moi qui ne
suis pas un expert apache.
J'ai besoin de l'aide de la liste pour me sortir de ce problème.
Philippe Merlin
Erwan David (02/11/2019, 17h40)
Le 02/11/2019 à 16:18, MERLIN Philippe a écrit :
[..]
> moins pour moi qui ne suis pas un expert apache.
> J'ai besoin de l'aide de la liste pour me sortir de ce problème.
> Philippe Merlin

Ça fait longtemps que je n'utilise plus apache, mais ce Require ça ne
serait pas une sytntaxe de Apache 2.2 invalide à partir de 2.4 ?
Jean-Michel OLTRA (02/11/2019, 18h00)
Bonjour,

Le samedi 02 novembre 2019, MERLIN Philippe a écrit...

> nov. 02 11:46:59 portable apachectl[1180]: AH00526: Syntax error on line 9 of /etc/
> apache2/mods-enabled/php7.3.conf:
> nov. 02 11:46:59 portable apachectl[1180]: Invalid command 'Require', perhaps misspelled
> or defined by a module not inclu>


???

Dans cette ligne 9 on retrouve "Require all denied"
Manu Baylac (02/11/2019, 18h40)
Bonjour,

Le 02/11/2019 à 16:18, MERLIN Philippe a écrit :

> Depuis quelque temps suite à une mise à jour apache2 ne démarre plus sur
> ma debian amd64 Sid à jour.
> Voilà les diagnostics :
> nov. 02 11:46:58 portable systemd[1]: Starting The Apache HTTP Server...
> nov. 02 11:46:59 portable apachectl[1180]: AH00526: Syntax error on line
> 9 of /etc/apache2/mods-enabled/php7.3.conf:
> nov. 02 11:46:59 portable apachectl[1180]: Invalid command 'Require',
> perhaps misspelled or defined by a module not inclu>


D'après


La directive "Required" est fournie par le module mod_authz_core .

Est-il bien toujours "enabled" ?
Support (02/11/2019, 19h00)
Bonjour
cela parle pas de ce que on voie, dans l'erreur , mais regarder ceci :



Bien à vous 
Michel

On Saturday, November 02, 2019 16:18 CET, MERLIN Philippe <phil-deb1.merlin> wrote:
  
Bonjour,
Depuis quelque temps suite à une mise à jour apache2 ne démarre plus sur ma debian amd64 Sid à jour.
Voilà les diagnostics :
nov. 02 11:46:58 portable systemd[1]: Starting The Apache HTTP Server....
nov. 02 11:46:59 portable apachectl[1180]: AH00526: Syntax error on line 9 of /etc/apache2/mods-enabled/php7.3.conf:
nov. 02 11:46:59 portable apachectl[1180]: Invalid command 'Require', perhaps misspelled or defined by a module not inclu>
nov. 02 11:46:59 portable apachectl[1180]: Action 'start' failed.
nov. 02 11:46:59 portable apachectl[1180]: The Apache error log may have more information.
nov. 02 11:46:59 portable systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
lorsque je regarde php7.3.conf à la ligne 9 et avant j'ai :
<FilesMatch ".+\.phps$">
   SetHandler application/x-httpd-php-source
   # Deny access to raw php sources by default
   # To re-enable it's recommended to enable access to the files
   # only in specific virtual host or directory
   Require all denied
J'ai bien recherché sur Google mais je n'ai rien trouvé d'évident du moins pour moi qui ne suis pas un expert apache.
J'ai besoin de l'aide de la liste pour me sortir de ce problème.
Philippe Merlin

 

 
MERLIN Philippe (02/11/2019, 20h00)
Le samedi 2 novembre 2019, 17:25:45 CET Manu Baylac a écrit :
> Bonjour,
> Le 02/11/2019 à 16:18, MERLIN Philippe a écrit :
> D'après
>
> La directive "Required" est fournie par le module mod_authz_core .
> Est-il bien toujours "enabled" ?
> --
> Manu

Merci à vous tous, effectivement le module authz_core n'était pasenabled, cela
m'a permis d'avancer et de m'apercevoir que plusieurs autres modules n'étaient
également pas enabled, maintenant apache fonctionne.
Encore Merci.
Philippe Merlin
Discussions similaires