gratifiant > comp.sys.* > comp.sys.atari

Pierre TON-THAT (26/05/2007, 21h26)
Houba yop yop :)

Nouvelle version de mon client FTP préparé avec amour. Download sur mon
site web (qui a déménagé), voire directement avec l'adresse
(96 Ko)

(tention, je sais pas si Club Internet aime les downloads directs, en
tout cas, on ne peut pas lister le contenu d'un dossier chez eux)

Nouveau snap :

Pour les nouveautés : (en gros, adaptation pour les vieux TOS)
- correction d'un bug dans le tri par nom (qui pouvait causer un
plantage sous MiNT)
+ tri par type, distinguer la casse ou non (Merci à _Dbug_)
+ quelques raccourcis claviers
+ explorateur de fichiers interne (plus confortable sous monoTOS,
Merci à Cooper pour l'idée)
+ ranger les fenêtres
+ comportements divers pour chaque signets :
. pointer vers le dossier de download à l'ouverture de connexion
. vérifier la place disque avant de sauver un fichier downloadé
(attention, la vérification ralentis le processus)
. convertir le nom du fichier au format DOS 8+3 (toujours fait si
l'environnement n'est ni MagiC ni MiNT)

Voilà. prochaine mise à jour dans, heu... un peu plus longtemps que
trois semaines. J'ai du Platon à lire, et il fait beau.

++

-- Pierre TON-THAT - Rajah Lone / Renaissance
OL (26/05/2007, 23h36)
Pierre TON-THAT a écrit :
> Houba yop yop :)
> Nouvelle version de mon client FTP préparé avec amour. Download sur mon
> site web (qui a déménagé), voire directement avec l'adresse
> (96 Ko)
> (tention, je sais pas si Club Internet aime les downloads directs, en
> tout cas, on ne peut pas lister le contenu d'un dossier chez eux)


Si ils acceptent le php, je peux te filer une petite routine qui permet
de lister le contenu d'un dossier et de naviguer.

Sinon super idée ton logiciel.

Olivier
[..]
Pierre TON-THAT (27/05/2007, 11h41)
Yop :)

OL a écrit :
> Si ils acceptent le php, je peux te filer une petite routine qui permet de
> lister le contenu d'un dossier et de naviguer.


php accepté, et j'ai trouvé un script qui-va-bien, équivalent à ce que
j'avais précédemment. Merci pour la suggestion :)

> Sinon super idée ton logiciel.


Merki.
L'idée vient que j'en ai marre d'aFTP, et que j'aimerais plus de
confort visuel et ergonomique.

++

-- Pierre TON-THAT - Rajah Lone / Renaissance
personnel (27/05/2007, 16h39)
Le Sat, 26 May 2007 19:26:18 +0000, Pierre TON-THAT a écrit :

[..]
> ++
> -- Pierre TON-THAT - Rajah Lone / Renaissance
>


bonjour!

Merci pour ce nouveau programme!
Au passage, j'ai redécouvert ta maison page!

Tes liens sympas en particulier sont pertinents valides
Bref, nikkel!
A+
jpierre
Jean-Luc (27/05/2007, 21h16)
Pierre TON-THAT a écrit :
> Houba yop yop :)


Bonsoir Pierre,
> Nouvelle version de mon client FTP préparé avec amour. Download sur mon
> site web (qui a déménagé), voire directement avec l'adresse
> (96 Ko)

Je me faisais une joie de tester cette nouvelle moûture, hélas! pour
moi, impossible de la télécharger, que ce soit avec HighWire ou CAB :-(
Je vais voir ce que ça donne avec le PC, en espérant avoir un peu plus
de succès - mais j'en serais fort étonné :-/
...
Bon, à partir du PC, ça a fonctionné. :-|
C'est donc un problème inhérent à nos machines :-/

Jean-Luc
Jean-Luc (27/05/2007, 21h27)
Pierre TON-THAT a écrit :
> Houba yop yop :)


Re- ;-)
> Nouvelle version de mon client FTP préparé avec amour. .../...

Bon, ben... toujours «Erreur 002» suivi d'une «Fehler #-254» lorsque je
tente d'accéder à certains répertoires du PC. :-(
Je me dis que c'est dû, soit à la quantité de fichiers qu'il contient,
soit à la longueur des noms de certains fichiers.
Je fais quelques essais, et je reviens faire mon rapport.

Jean-Luc
st_cooper (27/05/2007, 22h02)
Bonsoir Jean-Luc,

J'ai téléchargé l'archive à partir de mon STE, sous Cab. La page met
du temps à se charger, mais finit par se charger au final. Faut être
patient ;)

A+
Cooper.

On 27 mai, 21:16, Jean-Luc <Monprenom.Monnom@monfai> wrote:
[..]
Pierre TON-THAT (27/05/2007, 23h19)
Bonsoir

Jean-Luc a écrit :
>> Bon, ben... toujours «Erreur 002» suivi d'une «Fehler #-254» lorsque je

> tente d'accéder à certains répertoires du PC. :-(
> Je me dis que c'est dû, soit à la quantité de fichiers qu'il contient,
> soit à la longueur des noms de certains fichiers.


Pour la quantité de fichiers : quel est le max par répertoire chez toi ?
(Litchi a un buffer de 64Ko pour les directory, soit à peu prêt 800
fichiers par répertoire, ce qui devrait être assez suffisant, enfin, si
j'assume le fait que les gens sont soignés et accumulent pas les
fichiers comme à Capharnaüm).
Pour la longueur des noms longs, normalement, ça devrait pas poser de
problème.

Sinon, tu as mis quoi comme serveur FTP sur ton PC ? il est en mode
Unix (ou bien en mode zin/iis que j'ai pas testé) ? Je conseille
"FileZilla FTP Server" ; bien propre sur lui, on peut avoir plusieurs
comptes qui pointent vers des répertoires que l'on veut.

++

-- Pierre TON-THAT - Rajah Lone / Renaissance
Jean-Luc (27/05/2007, 23h54)
st_cooper a écrit :
> Bonsoir Jean-Luc,
> J'ai téléchargé l'archive à partir de mon STE, sous Cab. La page met
> du temps à se charger, mais finit par se charger au final. Faut être
> patient ;)


Effectivement, la page se charge bien, mais rien n'eset sauvegardé sur
le disque. Et lorsque je tente de sauvegarder le lien, aussi bien CAB
qu'HighWire m'annoncent qu'ils ne peuvent créer le fichier.
Et ce n'est pas un problème de place : il me reste largement de quoi
placer les malheureux 100 ko de l'archive sur ma partition, qui ne
compte que 380 Mo réels d'occupés sur le Go qu'elle peut contenir.
Je viens d'ailleurs - à l'instant même - de lancer le téléchargement de
DGEM sur cette même partition, et tout se déroule bien, tandis que
litchi, dont j'aiégalement dans la foulée, continue de me gratifier de
ses "can't create target file"! :-(
Je rencontre d'ailleurs exactement le même problème avec un autre site,
sur lequel certaines archives se chargent correctement, mais d'autres
me jettent pareillement. :-(
Et ce, quelle que soit la partition sur laquelle je tente de les
rapatrier. :-/

Jean-Luc
Jean-Luc (28/05/2007, 00h19)
Pierre TON-THAT a écrit :
> Bonsoir


Bonsoir Pierre,

Désolé pour le dérangement. :-(
> Pour la quantité de fichiers : quel est le max par répertoire chez toi ?
> (Litchi a un buffer de 64Ko pour les directory, soit à peu prêt 800
> fichiers par répertoire, ce qui devrait être assez suffisant, enfin, si
> j'assume le fait que les gens sont soignés et accumulent pas les
> fichiers comme à Capharnaüm).


Le répertoire en cause doit contenir un peu moins d'une centaine de
fichiers, et une vingtaine de sous-répertoires.
Pour contourner le problème, j'utilise un sous-répertoire de ce fameux
répertoire qui me pose problème, et alors tout se passe bien. Mais, si
j'ai le malheur de vouloir remonter d'un niveau, et donc de me
retrouver à la racine du répertoire problématique, d'abord il
"connecting...", puis, au bout d'un moment passé à "listing...",
badaboum! "erreur 002" (ça, je suppose que c'est litchi), suivi de
"Fehler #-254" (ça, je suis sûr que c'est MagiC!). :-(

> Pour la longueur des noms longs, normalement, ça devrait pas poser de
> problème.
> Sinon, tu as mis quoi comme serveur FTP sur ton PC ? il est en mode
> Unix (ou bien en mode zin/iis que j'ai pas testé) ? Je conseille
> "FileZilla FTP Server" ; bien propre sur lui, on peut avoir plusieurs
> comptes qui pointent vers des répertoires que l'on veut.


C'est justement celui-là que j'utilise. :-)
... petite interruption histoire de vérifier une idée qui vient de me
traverser l'esprit...
Ah! çà y est! j'ai trouvé! Litchi n'aime pas les accents dans les noms
des répertoires (et/ou des fichiers) : en rajoutant une accentuée dans
le nom du sous-répertoire «de contournement», badaboum! et, en sup-
primant les accentuées du répertoire «problématique», ça marche!
Donc, s'il y a une option pour ça dans Litchi, inutile d'intervenir,
je saurai trouver (vu le peu de réglages ;-) ). Sinon, ce serait peut-
être bien d'y songer pour la version de «pour dans quelques mois» ;-)

Jean-Luc - content je suis, si! si!
Pierre TON-THAT (28/05/2007, 07h41)
Bonjour

Jean-Luc a écrit :
> Ah! çà y est! j'ai trouvé! Litchi n'aime pas les accents dans les noms
> des répertoires (et/ou des fichiers) : en rajoutant une accentuée dans
> le nom du sous-répertoire «de contournement», badaboum! et, en sup-
> primant les accentuées du répertoire «problématique», ça marche!


Bizarre, le test avec un dossier comportant un accent fonctionnait sans
problème chez moi ("Dossier Système" sur MacOSX).

Les accents sont apparemment transmis au format UTF-8, ce qui complique
beaucoup la tâche si j'ai à faire une conversion vers le format Atari,
car cette conversion doit être bijective : je dois donner le nom
d'origine pour chaque commande FTP sur ce fichier. Avoir un nom
d'origine et un converti, ça va augmenter la taille mémoire...

Sinon, l'erreur 002 puis l'erreur MagiC, je pense que ça vient de
l'utilisation de ce nom (rendu bizarre avec l'UTF-8 ) dans le gadget
"ligne d'information" de la fenêtre. Tu utilises quoi comme windframe ?

Sinon, tu peux activer le fichier de log, pour lister le nom du
dossier, à partir du répertoire parent, et voir la gueule en UTF-8 ?
Merci.

> Donc, s'il y a une option pour ça dans Litchi, inutile d'intervenir,
> je saurai trouver (vu le peu de réglages ;-) ). Sinon, ce serait peut-
> être bien d'y songer pour la version de «pour dans quelques mois» ;-)


Je vois pas trop comment mettre une "option", c'est plutôt une fonction
pour contourner le problème.

++

-- Pierre TON-THAT - Rajah Lone / Renaissance
personnel (28/05/2007, 18h58)
Le Mon, 28 May 2007 17:54:55 +0000, Pierre TON-THAT a écrit :

> Bonsoir :)
> st_cooper a écrit :
> Pour ceux qui ont une configuration pas-de-la-mort-qui-tue-pas, je viens
> de bidouiller le script php (avec des bouts de php trouvés ça et là).
>
> Pour ceusses qui veulent pas se taper ma maison-page :p
> ++
> Rajah


Bonjour!

Personnellement, j'ai dit que je trouvais votre site perso, clair!
J'adore le coté le tout en 1 page, style moyen age, oyez, oyez!
C'est le coté de dérouler de la page en scroll, avec le meilleur pour la
fin, les liens , nouveaux pour moi!
Ces liens je ne les connaissais pas, na c'est dit!
Le site de bellamy ne semble plus actualisé?

A+
jpierre
Pierre TON-THAT (28/05/2007, 19h54)
Bonsoir :)

st_cooper a écrit :
> J'ai téléchargé l'archive à partir de mon STE, sous Cab. La page met
> du temps à se charger, mais finit par se charger au final. Faut être
> patient ;)


Pour ceux qui ont une configuration pas-de-la-mort-qui-tue-pas, je viens
de bidouiller le script php (avec des bouts de php trouvés ça et là).



Pour ceusses qui veulent pas se taper ma maison-page :p

++

Rajah
Bibou (31/05/2007, 23h36)
J'ai testé : fonctionnement excellent sur la config ci-dessous ;-)

Bravo Rajah, c'est excellent, comme toujours !

A+,

Bibou.

----------
Message posté sur Quadra 700 33 MHz 68 Mo (RAM)
Système 7.6.1 / MagiCMac 6.1 / Jinnee 2.5 / NVDI 5.03
MagXNet 1.3.9b.
Pierre TON-THAT (05/06/2007, 00h55)
Bonsoir

Jean-Luc a écrit :
> retrouver à la racine du répertoire problématique, d'abord il
> "connecting...", puis, au bout d'un moment passé à "listing...",
> badaboum! "erreur 002" (ça, je suppose que c'est litchi), suivi de
> "Fehler #-254" (ça, je suis sûr que c'est MagiC!). :-(


J'ai refait des tests... Je n'arrive pas à ravoir ces plantages, mais
un blocage (faut attendre le timeout de 30s) sur l'ouverture d'un
dossier comportant pleins d'accents. J'étais en mode ACTIF par erreur de
configuration. En mode PASSIF, ça marche parfaitement. Tu étais dans
quel mode ?

Je rappelle que le mode ACTIF est fortement déconseillé.

++

-- Pierre TON-THAT - Rajah Lone / Renaissance

Discussions similaires