gratifiant > alt.* > alt.os.mandrake

Sandrine (19/02/2006, 21h43)
une question j'arrive pas a instalée amule sa me dit Certains paquetages
demandés ne peuvent pas être installés :
amule-2.1.0-1.1.20060plf.i586 (car libwx_baseu-2.6.so.0 est non satisfait)
peut ton m'aider
merci
Gary (19/02/2006, 22h11)
Sandrine a écrit :
> une question j'arrive pas a instalée amule sa me dit Certains paquetages
> demandés ne peuvent pas être installés :
> amule-2.1.0-1.1.20060plf.i586 (car libwx_baseu-2.6.so.0 est non satisfait)
> peut ton m'aider
> merci


Bizarre, les dépendances devraient bien être gérées si les médias
d'installation sont bien paramétrés car cette bibliothèque fait partie
d'un paquetage plf :



++
Gary
Sandrine (20/02/2006, 07h41)
Gary a écrit :
> Sandrine a écrit :
> Bizarre, les dépendances devraient bien être gérées si les médias
> d'installation sont bien paramétrés car cette bibliothèque fait partie
> d'un paquetage plf :
>
> ++
> Gary


quand je clique sur le lien voila ceci

You have chosen search rpm in world FTP resources.
Not enough search parameters. I'm using defaults.
FILE WASN'T FOUND ON FTP SERVERS. TRYING TO SEARCH THIS FILE IN RPM
FILES CONTENT.
Not enough search parameters. I'm using defaults.

Your search wxGTK2.6-2.6.0-3.1.101plf.src.rpm did not match any entry in
database.
If you didn't do it, try add to searched space more distributions and
repositories.
Gary (20/02/2006, 09h22)
Sandrine a écrit :
[..]
> database.
> If you didn't do it, try add to searched space more distributions and
> repositories.


Pourquoi vouloir télécharger la source (qui d'ailleurs ne portent pas le
même nom) ? Le lien fournit donne accès au rpm précompilé pour mdk10.1.
Il faut juste choisir le serveur de téléchergement (dans la rubrique
Download, en-bas à droite avant la liste des fichiers fournis par le rpm) :
mandrake.contactel.cz ou ftp.pbone.net
Sandrine (20/02/2006, 09h57)
Gary a écrit :
> Sandrine a écrit :
> Pourquoi vouloir télécharger la source (qui d'ailleurs ne portent pas le
> même nom) ? Le lien fournit donne accès au rpm précompilé pour mdk10.1.
> Il faut juste choisir le serveur de téléchergement (dans la rubrique
> Download, en-bas à droite avant la liste des fichiers fournis par le rpm) :
> mandrake.contactel.cz ou ftp.pbone.net


je suis desolé mais j'ai essayer et je suis un peu perdu
peut tu me reexpliqué plus lentement merci
(je suis blonde aussi )
lol
Gary (20/02/2006, 10h23)
Sandrine a écrit :
> Gary a écrit :


[...]

>>> Your search wxGTK2.6-2.6.0-3.1.101plf.src.rpm did not match any entry
>>> in database.


[...]

> je suis desolé mais j'ai essayer et je suis un peu perdu
> peut tu me reexpliqué plus lentement merci
> (je suis blonde aussi )


mdr

Alors:

est un moteur de recherche de rpm

Je te conseille de faire une "Advanced RPM Search" afin de filtrer les
réponses pour la distribution souhaitée (Mandrake 10.X dans ton cas je
crois)

Dans la zone de recherche, tu rentres le nom du rpm recherché ou le nom
de la biblothèque voulue (ici : libwx_baseu-2.6.so.0). Ce qui donne :

Search results for libwx_baseu-2.6.so.0 :
Mandrake 10.X
carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/devel/10.2/i586/media/contrib/libwxgtku2.6-2.6.2-1.1.102mdk.i586.rpm
Mandrake 10.X
plf.zarb.org/plf/mandrake/free/10.2/i586/libwxgtku2.6-2.6.1-0.1.102plf.i586.rpm
Mandrake 10.X
plf.zarb.org/plf/mandrake/free/10.1/i586/libwxgtku2.6-2.6.0-3.1.101plf.i586.rpm
Mandrake 10.X
plf.zarb.org/plf/mandrake/free/10.0/i586/libwxgtku2.6-2.6.0-3.1.100plf.i586.rpm

Il faut donc choisir la version 10.x appropriée (10.1 dans le chemin ou
dans le nom du fichier), ce qui ouvre la page donnée en lien plus haut.

La partie supérieure de la page est consacrée à la présentation
(description, date, auteur, paquetage source à copmiler pour pouvoir
utiliser...)

Une autre partie correspond à des liens vers le contenu du rpm, les
informations de changement (changelog), dépendances...

Une troisième partie est consacrée au téléchargement (Download) avec une
liste de différents serveurs disposant de ce fichier prêt à l'emploi
(ici, il y en a 2 : mandrake.contactel.cz et ftp.pbone.net). Tu cliques
alors sur le nom du fichier en face du serveur que tu veux et le
téléchargement se lance :)
Dans cette partie, il y a aussi des paquetages prêts à l'emploi pour
d'autres architecture ordinateur (comme power pc architecture Macintosh)

Une fois le rpm téléchargé, tu l'installes en double cliquant dessus.

++
Gary

PS : par curiosité, as-tu déjà été sur pour
configurer les médias d'installation de paquetage ? Cela permet d'éviter
le genre de soucis que tu connais en automatisant la gestion des
dépendances (paquetages requis pour que d'autres fonctionnent).
Sandrine (20/02/2006, 15h50)
Gary a écrit :
[..]
> configurer les médias d'installation de paquetage ? Cela permet d'éviter
> le genre de soucis que tu connais en automatisant la gestion des
> dépendances (paquetages requis pour que d'autres fonctionnent).


oui j'ai eté sur le site easyurpmi j'ai fait ce que l'on ma dit mais le
il me demande autre chose Certains paquetages demandés ne peuvent pas
être installés :
libwxgtku2.6-2.6.0-3.1.101plf.i586 (car wxGTK2.6[>= 2.6.0] est non
satisfait)
Êtes-vous d'accord ?
Sandrine (20/02/2006, 16h12)
Gary a écrit :
[..]
> configurer les médias d'installation de paquetage ? Cela permet d'éviter
> le genre de soucis que tu connais en automatisant la gestion des
> dépendances (paquetages requis pour que d'autres fonctionnent).


il manque plein de paquetage j'arrive pas ça m'enerve !!!

oui je suis allé sur easy urpmi
Fauberteau Frédéric (21/02/2006, 07h43)
Sandrine a écrit :
> une question j'arrive pas a instalée amule sa me dit Certains paquetages
> demandés ne peuvent pas être installés :
> amule-2.1.0-1.1.20060plf.i586 (car libwx_baseu-2.6.so.0 est non satisfait)
> peut ton m'aider
> merci


J'ai eu aussi ce message car j'ai une distribution 64bits où les libs
sont installés dans /lib64 et /usr/lib64 et ce package d'amule est pour
les i586. Le package ne trouvent pas les libs sur le système (pas les
même répertoires). Je vais essayer de reconstruire le package sur ma
distrib 64bits.
Sinon, faut installer depuis les sources, mais ça fait un peu caca :-)
Gary (21/02/2006, 12h42)
Sandrine a écrit :
> Gary a écrit :


[...]

> oui j'ai eté sur le site easyurpmi j'ai fait ce que l'on ma dit mais le


peut-être un problème venant de plf :-/

> il me demande autre chose Certains paquetages demandés ne peuvent pas
> être installés :
> libwxgtku2.6-2.6.0-3.1.101plf.i586 (car wxGTK2.6[>= 2.6.0] est non
> satisfait)


Sandrine (21/02/2006, 17h36)
Sandrine a écrit :
> Gary a écrit :
> il manque plein de paquetage j'arrive pas ça m'enerve !!!
> oui je suis allé sur easy urpmi

tu habiterai pas en mayenne par hazard lol
Gary (21/02/2006, 17h47)
Sandrine a écrit :
> Sandrine a écrit :
> tu habiterai pas en mayenne par hazard lol


possible, j'ai pas l'accent pourtant lol
Sandrine (21/02/2006, 22h10)
Gary a écrit :
> Sandrine a écrit :
> possible, j'ai pas l'accent pourtant lol


parce que si tu avait habité en mayenne je t'aurais bien demandé de
venir m'aider ça aurait eté plus facile pour moi qui n'y arrive pas mais
bon je vais bien trouvé quelqu'un qui connait linux !!
parce que quand je dit que j'ai linux on me regarde avec des grand yeux
comme si je sortais d'une autre planete et non je ne suis plus sous
windows meme mon comptable ne me comprend pas ! lol
Fauberteau Frédéric (21/02/2006, 23h04)
J'ai eu le même problème que Sandrine, c'est-à-dire que lorque j'ai
voulu installer amule-2.1.0plf, j'ai obtenu ce message :
amule-2.1.0-1.1.20060plf.i586 (car libwx_baseu-2.6.so.0 est non satisfait).
Et pourtant, la bibliothèque est bien installé. Et j'ai compris quand
j'ai vu que c'était un paquet pour i586. Car j'ai un AMD64, donc pour
lui, il faut des paquets x86_64. C'est pour ça qu'il ne trouvait pas la
bibliothèque, car elle n'est pas au même endroit (lib64).
Alors si tu as toi aussi un AMD 64bits, je pense que ton problème vient
de là. Je pense l'avoir résolu en reconstruisant le paquet pour les
x86_64. En tout cas, mon paquets amule-2.1.0plf reconstruit fonctionne.
A vous de tester ...
Pour l'installer, il faut ajouter une source personnalisée dans le
gestionnaire des médias (comme pour plf) avec comme type de serveur :
HTTP, comme URL : et comme chemin
relatif hdlist : ./hdlist.cz

Voilà, ensuite, en faisant une mise à jour, le gestionnaire de média va
trouver la nouvelle version de amule et l'installer.

Dites-moi si ça marche
Sandrine (22/02/2006, 07h53)
Fauberteau Frédéric a écrit :
[..]
> Voilà, ensuite, en faisant une mise à jour, le gestionnaire de média va
> trouver la nouvelle version de amule et l'installer.
> Dites-moi si ça marche


j'ai fait la mise a jour mais il le trouve pas il reste sur la i586

Discussions similaires