gratifiant > microsoft.* > microsoft.excel

ThomasMa (07/11/2019, 16h09)
Bonjour la communauté !

J'ai un petit soucis et je suis plutôt débutant...
Sur mes lignes de livraisons j'ai un nom de destinataire dans une colonne, l
date de livraison dans une autre et enfin son métrage dans une troisième.
Comment additionner/fusionner les métrages dans le cas où la date est identiqu
et le destinataire aussi à l'aide d'une simple formule ou de VBA ?
MichD (07/11/2019, 16h37)
Le 07/11/19 à 09:09, ThomasMa a écrit :
> Bonjour la communauté !
> J'ai un petit soucis et je suis plutôt débutant...
> Sur mes lignes de livraisons j'ai un nom de destinataire dans une colonne, la
> date de livraison dans une autre et enfin son métrage dans une troisième.
> Comment additionner/fusionner les métrages dans le cas où la date est identique
> et le destinataire aussi à l'aide d'une simple formule ou de VBA ?


Bonjour,

En colonne A1:A25 : Nom des destinataires
En colonne B1:B25 : Date de livraison
En colonne C1:C25 : Métrage

Suppose que tu veux savoir le kilométrage total de l'individu "toto"
pour une date particulière située dans la cellule B2

=SOMMEPROD((A1:A25="toto")*(B1:B25=B2)*(C1:C25))

Si tu préfères taper une date précise dans la formule :
=SOMMEPROD(A1:A25="toto")*(B1:B25="7/11/2019"*1)*(C1:C25))

Les plages de cellules doivent avoir le même nombre de lignes.

MichD
cb1moa (07/11/2019, 17h15)
Le jeudi 07 Novembre 2019 à 15:09 par ThomasMa :
> Bonjour la communauté !
> J'ai un petit soucis et je suis plutôt débutant...
> Sur mes lignes de livraisons j'ai un nom de destinataire dans une colonne, la
> date de livraison dans une autre et enfin son métrage dans une
> troisième.
> Comment additionner/fusionner les métrages dans le cas où la date
> est identique et le destinataire aussi à l'aide d'une simple formule ou
> de VBA ?

Bonjour Thomas,
A quoi ressemble ton tableau ? Est-ce que tu mets tous tes clients et dates dan
le même fichier ? ou as-tu une feuille par client ?

De prime abord, je dirais que si tu veux te le faire manuellement, tu peux fair
tout simplement
=somme(B7:B27) si tes métrages sont dans la colonne B (20 lignes dans le ca
présent).

Sinon, soit tu peux utiliser la fonction =si(...) mais ça peut être fastidieu
si tu as beaucoup de clients.

As-tu pensé à utiliser la fonction filtre des données ? C'est simpl
d'utilisation et assez pratique.

As-tu pensé à utiliser les tableaux croisés dynamiques ? Tu pourrais regroupe
tous tes clients en fonction de la date et/ou sélectionner un seul client. T
ferais apparaître au centre les métrages.

Bon après-midi
thomasma (08/11/2019, 13h17)
Le jeudi 07 Novembre 2019 à 16:15 par cb1moa :
[..]
> regrouper tous tes clients en fonction de la date et/ou sélectionner un seul
> client. Tu ferais apparaître au centre les métrages.
> Bon après-midi Bonjour,


J'ai réussi à résoudre mon problème avec un croisé dynamique.

Merci pour votre réponse !
Discussions similaires