gratifiant > microsoft.* > microsoft.excel

David (06/02/2010, 17h39)
Bonjour à tous,

Comment obtenir la somme de toutes les
cellules jusque la 1ere cellule vide de la colonne D
part exemple.
Sous XP, Excel 2003 et VBA.

Merci à tous.
David (06/02/2010, 18h06)
Re-Boujour,

Je me réponds à moi-même :

Adresse = Range("D2:D65536").End(xlDown).Row
Formule = "=SUM(D2:D" & (Adresse - 1) & ")"
Range("D" & Adresse + 2).Value = Formule

S'i y a mieux je suis preneur.

Merci.
michdenis (06/02/2010, 18h12)
Bonjour,

Une suggestion...

Si après la première ligne vide, tu n'as pas de saisie de données
dans le reste de la colonne, tu peux utiliser :
=Somme(D:D) -> fait la somme de la colonne D

En VBA -> X = Application.Sum(range("D:D"))

Pour additionner de D1 à Dx x étant la première ligne vide
rencontrée :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(INDIRECT("D1:D"&MIN(SI(NBCAR(D:D)=0;LIGNE(D :D)))))

"David" <bs173990> a écrit dans le message de groupe de discussion :
OTPrhK0pKHA.1552...
Bonjour à tous,

Comment obtenir la somme de toutes les
cellules jusque la 1ere cellule vide de la colonne D
part exemple.
Sous XP, Excel 2003 et VBA.

Merci à tous.
michdenis (06/02/2010, 18h26)
Et cette syntaxe :

With Range("D2:D" & Range("D65536").End(xlUp).Row - 1)
.Offset(.Rows.Count + 3).Resize(1).Formula = "=Sum(" & .Address & ")"
End With

"David" <bs173990> a écrit dans le message de groupe de discussion :
unsoTZ0pKHA.5760...
Re-Boujour,

Je me réponds à moi-même :

Adresse = Range("D2:D65536").End(xlDown).Row
Formule = "=SUM(D2:D" & (Adresse - 1) & ")"
Range("D" & Adresse + 2).Value = Formule

S'i y a mieux je suis preneur.

Merci.
David (06/02/2010, 18h49)
Bonjour,

Merci pour vos réponses.
Je ne sais pas ou vous allez chercher tout cela;
à mon avis vous devez avoir 2 cerveaux :-))
Discussions similaires