gratifiant > microsoft.* > microsoft.excel

Pierreed (16/05/2018, 16h02)
Bonjour,

Je cherche à déterminer le nombre d’occurrences sur deux colonnes d'un fichie
excel.

Je m'explique, c'est un fichier excel qui est amener à évoluer avec des valeur
dans la colonne A qui sont inconnu.

Si nous prenons le tableau suivant pour exemple :

A B
1 FKX 1
2 FKX 1
3 FKX 2
4 FKW 1
5 FKW 1
6 FKZ 1
7 FKZ 2
8 FKZ 3

La formule doit me dire qu'il y a uniquement 6 données différentes.

Comme souligner précédemment, le plus difficile est de considérer que le
valeurs à venir sont inconnu et que le tableau, une fois terminé, devrai
mesurer environ 5000 lignes.

Dans l'attente de votre aide,

Pierreed
Michd (16/05/2018, 16h41)
Bonjour,

MD est le nom de la plage nommée de cellules.
Si les colonnes A et B ne contiennent pas des lignes vides, tu peux utiliser la fonction "Decaler"
pour définir le nom.
Un exemple en supposant que tu as des étiquettes de colonnes sur la ligne 1 :
=NBVAL(DECALER($A$1;;;NBVAL(A:A)1;2))
Comme cela, au fur et à mesure que tu saisis tes données, la plage de cellule représentée par MD va
se mettre à jour.

=SOMMEPROD(1/NB.SI(MD;MD))

MichD
Michd (16/05/2018, 16h46)
Dans cette formule, il manque le signe "-"
et la fonction "NbVal" est à supprimer. Désolé.

Voici la correction :
=DECALER($A$1;;;NBVAL(A:A)-1;2)

MichD
pierreed (16/05/2018, 18h09)
Le mercredi 16 Mai 2018 à 16:41 par Michd :
[..]
> se mettre à jour.
> =SOMMEPROD(1/NB.SI(MD;MD))
> MichD Merci de votre réponse,


Toutefois, je n'ai pas besoin mise à jour automatique puisque je vais devoi
figer dans le temps l'avancement des données saisies.

Même si votre solution etait bonne, une simple formule pour me dire combien d
lignes différentes compose mon tableau me suffit :-)

Avez vous une solution "plus simple" à mon problème ?
Michd (16/05/2018, 18h19)
| Avez vous une solution "plus simple" à mon problème ?

=SOMMEPROD(1/NB.SI(A1:B8;A1:B8))

Cette formule ne fonctionne pas ou est elle trop compliquée?

MichD
pierreed (17/05/2018, 09h27)
Le mercredi 16 Mai 2018 à 18:19 par Michd :
> | Avez vous une solution "plus simple" à mon problème ?
> =SOMMEPROD(1/NB.SI(A1:B8;A1:B8))
> Cette formule ne fonctionne pas ou est elle trop compliquée?
> MichD Super c'est exactement ce que je cherchais !


Merci
Discussions similaires