gratifiant > microsoft.* > microsoft.excel

Mikus (13/02/2018, 17h33)
Bonjour,

J'ai maintenant un fichier qui comporte aussi 2 tableaux (un en feuil1 e
l'autre en feuil2).

j'aimerais que lorsque je met une couleur de fond vert sur une cellule d'un
ligne de mon tableau2, la valeur de celle ci se reporte dans la colonne de mo
premier tableau.

Mon tableau 2 présente en chaque debut de ligne un produit, et a chaque colonn
un fournisseur (et donc dans chaque cellule le prix fournisseur). Le choix de l
cellule à mettre en vert correspond à mon choix fournisseur (en fonction d
produit).

Exemple :
Admettons que je dispose de 5 lignes (5produits), et de 3 colonne
(3fournisseurs). J'aurai une fois mon tableau rempli : 5 cellules à fond ver
(une sur chaque ligne).

Les 5 cellules devront alors être reportées automatiquement dans la colonn
"Prix fournisseur" de mon premier tableau (feuil1).

Voici la formule que j'ai essayer sans succès
=SI(couleur(Feuil2!C4:G4;10);"";Feuil1!G4)

Cette manœuvre est-elle possible sans code VBA ?

Merci pour vos réponses !
Michd (13/02/2018, 18h37)
Bonjour,

Oui c'est possible. Cependant, il faut faire appel à une fonction XL4, il y
a très longtemps.

Voici comment procéder.
A ) Tu dois créer un nom ("Name") en utilisant ce type de formule
Nom : EnCouleur
Fait référence à : (Adapte le type de référence. Le numéro
de la ligne n'a pas besoin d'une référence absolue.
=LIRE.CELLULE(63; Feuil1!$A$1)

B ) Dans la cellule de ton choix, tu inscris :
=EnCouleur
Tu peux transformer cette formule comme ceci :
=SI(EnCouleur=6;"OK";"Non OK") '6 étant la couleur jaune dans mon
environnement

Dans la cellule s'afficha la valeur numérique de la propriété
"ColorIndex" de la cellule, l'équivalent de la ligne de code suivante : a =
Range("A1").Interior.ColorIndex

Il y a un "HIC" à cette manière de procéder, pour faire la mise à jour de la
formule si le contenu de la couleur de fond de la cellule est modifié, il
appelé le recalcul de la feuille. Raccourci clavier F9 dans mon
environnement. Sinon la formule ne se met pas à jour.

MichD
Discussions similaires